Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 877237 - [RFE] UI: need better visual feedback on invalid/missing values in text fields
Summary: [RFE] UI: need better visual feedback on invalid/missing values in text fields
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Moran Goldboim
QA Contact: Pavel Stehlik
URL:
Whiteboard:
: 1029345 1034934 (view as bug list)
Depends On:
Blocks: RHEV-RHCI
TreeView+ depends on / blocked
 
Reported: 2012-11-16 01:47 UTC by Bryan Yount
Modified: 2018-12-04 14:52 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-01 12:23:45 UTC
oVirt Team: UX
sgrinber: Triaged+


Attachments (Terms of Use)
current validation pattern (deleted)
2017-11-01 12:28 UTC, Greg Sheremeta
no flags Details

Comment 1 Marina 2012-11-16 20:52:29 UTC
I completely understand this request. It bothers me myself a lot as well.
We can print a red/orange error/warning message on top/bottom of the dialogue box in addition to highlighting the text field.

Comment 2 Einav Cohen 2013-02-14 17:17:33 UTC
after talking to Simon:

- we are already in progress of changing the color or the border to a more noticeable one.

- user needs to understand that once he clicked on "ok" - there is something "in progress" - maybe worth forcing a progress-animation for 1 sec (or even less) so he will get that.

- in a multi-section dialog (e.g. New VM) sometimes the error is in a different section than the currently-selected one; need to keep that in mind as well (maybe worth jumping to the relevant section upon "ok" click?)

Comment 3 Einav Cohen 2013-02-14 17:30:36 UTC
*** Bug 711938 has been marked as a duplicate of this bug. ***

Comment 4 Daniel Erez 2013-11-17 07:31:44 UTC
*** Bug 1029934 has been marked as a duplicate of this bug. ***

Comment 5 Einav Cohen 2013-11-18 15:11:40 UTC
*** Bug 1029345 has been marked as a duplicate of this bug. ***

Comment 6 Einav Cohen 2013-11-18 15:20:50 UTC
BZ Description:

The highlights (border) around the text boxes in the AdminPortal and PowerUserPortal are not distinct enough to catch the user's attention when an invalid or missing entry is detected. 
since this indication is easily missed, it may seem as if clicking on "OK" either does nothing or in progress for a long time, when in fact user input should be adjusted (causes user unnecessary waste of time).

Solution Suggestions:

- Perhaps, in addition to the highlight, the window could shake back and forth - similar to Gnome's gdm or OS X's authentication windows... or something along those lines.

- see some suggestions in comment #2

- http://dribbble.com/shots/198390-Form-Field-Validation

- [from duplicate bug 1029345] change OK button style to indicate that there are validation errors.

Comment 7 Daniel Erez 2013-11-27 10:04:06 UTC
*** Bug 1034934 has been marked as a duplicate of this bug. ***

Comment 9 Einav Cohen 2014-05-19 18:25:32 UTC
*** Bug 1098600 has been marked as a duplicate of this bug. ***

Comment 10 Einav Cohen 2014-07-02 21:33:15 UTC
this can be accomplished by converting our fields and validation-messages to patternfly fields and validation messages. this task is too large for 3.6, so this is currently planned for 4.0.

Comment 14 Moran Goldboim 2017-11-01 12:23:45 UTC
not prioritized for a while, closing

Comment 15 Greg Sheremeta 2017-11-01 12:28:33 UTC
Created attachment 1346485 [details]
current validation pattern

Fyi, this is the current validation pattern. It should be adequate.


Note You need to log in before you can comment on or make changes to this bug.