Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87720 - Anaconda crashed when using LVM while partitioning / formatting
Summary: Anaconda crashed when using LVM while partitioning / formatting
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-01 19:12 UTC by David Blundell
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-29 20:48:48 UTC


Attachments (Terms of Use)
Anaconda dump (deleted)
2003-04-01 19:13 UTC, David Blundell
no flags Details
kickstart file produced during installation (deleted)
2003-04-18 16:14 UTC, David Blundell
no flags Details
parted view of partition table (deleted)
2003-04-18 16:15 UTC, David Blundell
no flags Details

Description David Blundell 2003-04-01 19:12:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
The anaconda installer crashed during installation of RHL 9  The traceback
indicated that LVM was at fault.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Manually partition
2.Create an LVM partition containing  /var  /data and some free space
3.Select packages and continue
    

Actual Results:  Anaconda crashed

Expected Results:  Partitioning and formatting.

Additional info:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 936, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 155, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 761, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 157, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 225, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 464, in turnOnFilesystems
    thefsset.createLogicalVolumes(instPath)
  File "/usr/lib/anaconda/fsset.py", line 1130, in createLogicalVolumes
    entry.device.setupDevice(chroot)
  File "/usr/lib/anaconda/fsset.py", line 1641, in setupDevice
    raise SystemError, "pvcreate failed for %s" % (volume,)
SystemError: pvcreate failed for <fsset.PartitionDevice instance at 0x8a67f4c>

Local variables in innermost frame:
volume: <fsset.PartitionDevice instance at 0x8a67f4c>
node: /dev/sda5
chroot: /mnt/sysimage
devPrefix: /tmp
nodes: []
rc: 1280
self: <fsset.VolumeGroupDevice instance at 0x89a6274>


For full dump see attachment.

Comment 1 David Blundell 2003-04-01 19:13:57 UTC
Created attachment 90814 [details]
Anaconda dump

Comment 2 Jeremy Katz 2003-04-02 20:31:10 UTC
What did you select to do for your partitioning?

Comment 3 David Blundell 2003-04-18 16:14:47 UTC
Created attachment 91189 [details]
kickstart file produced during installation

Comment 4 David Blundell 2003-04-18 16:15:25 UTC
Created attachment 91190 [details]
parted view of partition table

Comment 5 David Blundell 2003-04-18 16:20:58 UTC
The server was a new Dell Poweredge 2650 with two SCSI drives running hardware
RAID.  Dell factory install a vfat partition at the beginning of the disk.  I
chose to automatically partition the existing structure and review changes.  I
kept the vfat partition and then created a large LVM partition containing /var
and /data.

I went through the rest of the installation options and when the installer began
to format the system it crashed with the traceback shown above.

I initialized the raid array to remove any existing data (including the vfat
partition) and began a new installation choosing auto-partitioning again.  I
modified the results to give / /boot and swap with an LVM containing
/var/spool/postfix /home and /var  This time the installer finished and rebooted
- the problem was that it had mixed the sizes of the / and swap partitions - I
wanted a 2Gb swap and 7Gb / but it gave me a 7Gb swap and a 2Gb /.  I have
attached the kickstart file produced along with a copy of the parted view of the
partition table.  This shows that a 7Gb / was selected but a 2Gb / was produced.

I have been through the installation a third time, selecting manual partitioning
and not adding any LVM - I left enough space to add the LVM after the
installation.  The installation went smoothly and the machine is now in use.

Comment 6 Jeremy Katz 2003-06-29 20:48:48 UTC
Added some additional checks to prevent this from happening.


Note You need to log in before you can comment on or make changes to this bug.