Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87685 - [RFE] cannot add systems from a group to the systems selection
Summary: [RFE] cannot add systems from a group to the systems selection
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site
Version: RHN Stable
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: rhn-dev-list
QA Contact: Red Hat Network Quality Assurance
URL:
Whiteboard: us=54971
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-01 08:32 UTC by Patrick C. F. Ernzer
Modified: 2011-07-07 18:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-07 18:42:24 UTC


Attachments (Terms of Use)

Description Patrick C. F. Ernzer 2003-04-01 08:32:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
When viewing a group and selecteing systems, the selected systems do not appear
to get selected

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. log onto RHN as 'pcfe'
2. make sure the system selection set is empty
3. open a group (e.g. 'always on')
4. click 'Select All'
5. note that system set stays empty
6. click 'Update List'
    

Actual Results:  No systems selected (verified by 'Manage', 'List the systems')

Expected Results:  Systems selection as chosen

Additional info:

Selecting the systems from the global systems list works fine

Comment 1 Bret McMillan 2003-04-01 14:45:20 UTC
Selection from the systems list is what lets you remove systems from a group.

If you want to use the systems in the group with the SSM, use the 'Work With
Group' icon.

Comment 2 Patrick C. F. Ernzer 2003-04-02 17:43:56 UTC
reopening after discussion with bretm.

notes:

I can only reporduce this on my 'pcfe' account. the 'pernzer' account (an org
sub account) does not offer selection boxes when listing the systems in a group.

While the way bretm suggested does work, it is counter-intuitive. the list of
systems in a group should work like the global systems list.

Comment 3 Red Hat Bugzilla 2007-02-05 19:30:23 UTC
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.

Comment 4 Bill C. Riemers 2008-02-13 21:48:40 UTC
Seems like the current implementation works as designed and is reasonably intuitive.

Comment 5 daryl herzmann 2008-04-06 04:00:06 UTC
Hi,

I am currently seeing this bug on RHN hosted 5.0.5

1) List out systems in some group. (/network/systems/groups/system_list.pxt)
2) Click some of the systems listed or "Select All"
3) Click "Update List"

Result: no systems are added to the SSM.

I can add systems from here tho: (/rhn/systems/SystemList.do) , so all hope is
not lost :)

daryl

Comment 6 Máirín Duffy 2008-04-08 15:26:53 UTC
this bug still affects customers. (see comment 5). It may only affect a limited
set of customers or customers with particular attributes linked with their
account (see comment 2) but it's definitely a bug still.

note that this bug does not affect the 'use in ssm' buttons on
https://rhn.redhat.com/rhn/systems/SystemGroupList.do. It affects the 'update
list' button on the listview on
https://rhn.redhat.com/network/systems/groups/system_list.pxt?sgid= 

When you select systems on that page and hit update list, the ssm system count
is not updated. It may be a bug in the js that updates the grey SSM bar counter,
but Daryl from comment 5 just confirmed that the systems are not actually
getting added to the SSM system list either so that is definitely part of the bug.

reopening bug...

Comment 7 Grant Gainey 2008-04-18 16:28:27 UTC
OK - I think the confusion here is that the checkboxes are *primarily* intended
to be selectors for the "Remove from Group" submit.  However, "Update List" in
other places in RHN affects the SSM list.

I think it would make *more* sense to remove "Update List" entirely.  Right now,
it would be (to me, anyway) completely not-obvious that "Update List" modifies
the SSM set.  Perhaps we can reword the page's text to make it more clear what
one is accomplishing from here (i.e., this is the place to remove systems from a
server group, not to add systems to the SSM.

Comment 8 Amy Owens 2008-10-16 18:06:36 UTC
keeping this one open - added user story: http://wwwapps.rdu.redhat.com:8080/xplanner/do/view/userstory?oid=54971


Note You need to log in before you can comment on or make changes to this bug.