Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87648 - Instant ISO Server Problem
Summary: Instant ISO Server Problem
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site
Version: RHN Stable
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike Orazi
QA Contact: Amy Owens
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-31 21:01 UTC by phostetl
Modified: 2008-04-21 14:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-04-21 14:58:51 UTC


Attachments (Terms of Use)

Description phostetl 2003-03-31 21:01:35 UTC
Description of problem:

Following the instructions to fetch an ISO using curl per the web site gives
this error upon resuming a transfer:

$ curl -C - -O
'http://rhn.redhat.com/download/1049128277/f9766a198ec7a711c08e3662f41c3217e63886a4/314115/7705/local/isos/Shrike/shrike-i386-disc2.iso'
** Resuming transfer from byte position 150177507
  % Total    % Received % Xferd  Average Speed          Time             Curr.
                                 Dload  Upload Total    Current  Left    Speed
  0     0    0     0    0     0      0      0 --:--:--  0:00:50 --:--:--     0
curl: (33) HTTP server doesn't seem to support byte ranges. Cannot resume.



Version-Release number of selected component (if applicable):


How reproducible:
Always.  At least when the server is up. :/

Steps to Reproduce:
1. Log into RHN.
2. Follow instructions to grab instant ISO using curl.
3. Have transfer interrupted.
4. Resume transfer with same curl command.
5. Observe error message.
    
Actual results:
Error message:
curl: (33) HTTP server doesn't seem to support byte ranges. Cannot resume.

Expected results:
Shiny new ISO.

Additional info:
Even with a fat pipe an ISO image is no small file.  Resuming file transfers can
be a good thing. :)

Comment 1 Chip Turner 2003-04-14 15:39:36 UTC
typically this message is when the URL expires (they have finite lifetime). 
returning to the ISO page and getting a new URL for the same ISO image should
allow you to reusme from where you left off

Comment 2 Mike Orazi 2008-04-21 14:58:51 UTC
Cleaning out the bz backlog.  Since it has been quite a while, and I can resume
downloads as outlined above, I'm going to close and second Chip's explanation.



Note You need to log in before you can comment on or make changes to this bug.