Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87638 - ps shows processed as swap while no swap in use
Summary: ps shows processed as swap while no swap in use
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel
Version: 2.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Don Howard
QA Contact: Brian Brock
URL:
Whiteboard:
: 89513 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-31 15:54 UTC by Christian Stelter
Modified: 2007-11-30 22:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-11 23:37:55 UTC


Attachments (Terms of Use)

Description Christian Stelter 2003-03-31 15:54:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
today we updated an AS to kernel kernel-smp-2.4.9-e.16 

after the update processes which are not swaped out are marked as in swap:

# ps axuw|grep squid
root      1540  0.0  0.0  3796 1124 ?        S    16:04   0:00 [squid]
web       1542 30.4  1.1 50852 46456 ?       S<   16:04  31:25 [squid]
root      1909  0.0  0.0  3804 1132 ?        S    16:05   0:00 [squid]
web       1911 27.9  1.0 46152 41736 ?       S<   16:05  28:52 [squid]
root     18331  0.0  0.0  1452  452 pts/1    S    17:48   0:00 grep squid

Mem:  3927700K av,  786776K used, 3140924K free,     364K shrd,  106484K buff
Swap: 1847464K av,       0K used, 1847464K free                  490196K cached

  PID USER     PRI  NI  SIZE  RSS SHARE STAT %CPU %MEM   TIME COMMAND
 1911 web       13  -2 41752  40M  1320 S <  29.5  1.0  29:02 squid
 1542 web       13  -2 46472  45M  1320 S <  27.9  1.1  31:37 squid

Uh? Because of this bug our server monitoring fails. :-(

Version-Release number of selected component (if applicable):
procps-2.0.7-11

How reproducible:
Always

Steps to Reproduce:
1. ps axuw (or ps -efa)


Actual Results:  # ps -efa|grep squid
root      1540     1  0 16:04 ?        00:00:00 [squid]
web       1542  1540 30 16:04 ?        00:32:14 [squid]
root      1909     1  0 16:05 ?        00:00:00 [squid]
web       1911  1909 27 16:05 ?        00:29:31 [squid]
root     18965 10824  0 17:51 pts/1    00:00:00 grep squid

Expected Results:  # ps -efa|grep squid
root     26493     1  0 05:23 ?        00:00:00 /server/www/squid/bin/squid -f /
web      26496 26493 26 05:23 ?        03:21:50 (squid) -f /server/www/squid/etc
root     26497     1  0 05:23 ?        00:00:00 /server/www/squid/bin/squid -f /
web      26499 26497 26 05:23 ?        03:15:30 (squid) -f
/server/www/squid/etcroot      8817  8705  0 17:51 pts/1    00:00:00 grep squid

Additional info:

Kernel-Update -> 2.4.9-e.16

Comment 1 Alexander Larsson 2003-04-01 12:47:53 UTC
The brackets are added when the file /proc/$pid/cmdline is empty. Is this
happening with the new kernel?


Comment 2 Christian Stelter 2003-04-01 13:55:59 UTC
After an restart (automatic, every night) the parent process has its cmdline
correctly. 

Only the child processes now have brackets (and empty cmdlines). On a system
with 2.4.9-e.3smp kernel the child have a cmdline.

--- 1. new kernel system (2.4.9-e.16smp):

web      27679 18.4  3.3 133828 132188 ?     R    05:21 114:23 [squid]
web      27680 19.5  2.5 99908 98388 ?       S    05:21 121:26 [squid]
root     27674  0.0  0.0  3800 1128 ?        S    05:21   0:00
/server/www/squid/bin/squid -f /server/www/squid/etc/squid1.conf
root     27676  0.0  0.0  3800 1128 ?        S    05:21   0:00
/server/www/squid/bin/squid -f /server/www/squid/etc/squid2.conf

# cat /proc/27679/cmdline
#

--- 2. old kernel system (2.4.9-e.3smp)
root     21666  0.0  0.0  3828 1108 ?        S    05:23   0:00
/server/www/squid/bin/squid -f /server/www/squid/etc/squid1.conf
root     21669  0.0  0.0  3828 1108 ?        S    05:23   0:00
/server/www/squid/bin/squid -f /server/www/squid/etc/squid2.conf
web      21670 17.5  6.4 134104 132396 ?     S    05:23 109:24 (squid) -f
/server/www/squid/etc/squid1.conf
web      21672 18.5  4.3 91008 89332 ?       S    05:23 115:57 (squid) -f
/server/www/squid/etc/squid2.conf


# cat /proc/21672/cmdline
(squid)-f/server/www/squid/etc/squid2.conf



Comment 3 Alexander Larsson 2003-04-02 09:55:21 UTC
I have no idea why this is happening, but it seems to be a kernel issue, so I'm
reassigning this to the kernel module.

Comment 4 Christian Stelter 2003-04-09 08:09:31 UTC
Any new insights?

The problem persists.

Comment 5 Nick (Gunnar) Bluth 2003-04-24 13:13:18 UTC
We experience the same problems since update to 2.4.9-e16enterprise. 
 
Since then, we also had kernel panics caused by process "ps" on 2 completely idle 
boxes (Easter monday and and midnight). 
 
Also, Patrol is heavily irritated.... 

Comment 6 Alexander Larsson 2003-04-24 15:50:20 UTC
*** Bug 89513 has been marked as a duplicate of this bug. ***

Comment 7 Ivan Martinez 2003-04-29 23:01:50 UTC
I have the same problem on RedHat 9.
Kernel 2.4.20-9
I checked the /proc/pid/cmdline and it's empty in the case, the processes are
not swapped. 
(1.5G RAM) and sendmail processes are sending/receiving mail, and they appear
without cmdline.


Comment 8 Jean-David Beyer 2003-05-14 10:57:17 UTC
The same thing seems to be happening in Red Hat Linux 7.3.
When up2date upgraded the kernel from vmlinuz-2.4.18-26.7.xsmp to
vmlinuz-2.4.18-27.7.xsmp, programs like sendmail and IBM's DB2 UDB V6.1 stopped
recording the correct process names in ps and top commands.

Comment 9 Jean-David Beyer 2003-05-14 13:06:53 UTC
Here are some results (output of "top" command) using each of two kernels. The
older kernel gives the desired output, the new one does not:

vmlinuz-2.4.18-26.7.xsmp kernel:

 1126 root      15   0  1416 1416  1000 S     0.0  0.2   0:00 sendmail:
accepting connections     
 1132 smmsp     17   0  1312 1312   976 S     0.0  0.2   0:00 sendmail: Queue
runner@00:02:00 for /var/spool/
 1371 root      17   0  8700 8700  8580 S     0.0  1.6   0:00 db2wdog          
                  
 1372 db2inst1  15   0 15104  14M 14964 S     0.0  2.9   0:00 db2sysc          
                  
 1373 root      15   0 11084  10M 11004 S     0.0  2.1   0:00 db2gds           
                  
 1374 db2inst1  17   0 11212  10M 11068 S     0.0  2.1   0:00 db2ipccm         
                  
 1375 db2inst1  18   0 15072  14M 14936 S     0.0  2.9   0:00 db2tcpcm         
                  
 1376 db2inst1  16   0 11144  10M 11024 S     0.0  2.1   0:00 db2resyn         
                  
 1377 db2inst1  16   0 11140  10M 11008 S     0.0  2.1   0:00 db2srvlst        
           


vmlinuz-2.4.18-27.7.xsmp kernel:

 1003 root      15   0  1416 1416  1000 S     0.0  0.2   0:00 sendmail
 1009 smmsp     17   0  1308 1308   976 S     0.0  0.2   0:00 sendmail
 1248 root      17   0  8704 8704  8580 S     0.0  1.6   0:00 db2sysc
 1249 db2inst1  15   0 15108  14M 14968 S     0.0  2.9   0:00 db2sysc
 1250 root      15   0 11088  10M 11012 S     0.0  2.1   0:00 db2sysc
 1251 db2inst1  18   0 11216  10M 11072 S     0.0  2.1   0:00 db2sysc
 1252 db2inst1  18   0 15080  14M 14944 S     0.0  2.9   0:00 db2sysc
 1253 db2inst1  16   0 11148  10M 11032 S     0.0  2.1   0:00 db2sysc
 1254 db2inst1  16   0 11144  10M 11012 S     0.0  2.1   0:00 db2sysc


Comment 10 Jim Zimmerman 2003-09-16 21:01:26 UTC
On my RedHat 7.2 machine, this problem was resolved when I upgraded my kernel to
2.4.20-20.7smp.

Comment 12 Don Howard 2006-09-11 23:37:55 UTC
This is a very old issue and is not critical or security-related.


Note You need to log in before you can comment on or make changes to this bug.