Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87631 - Wrong SDRAM size for IXDP425 Evaluation Board
Summary: Wrong SDRAM size for IXDP425 Evaluation Board
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: eCos
Classification: Retired
Component: HAL
Version: CVS
Hardware: xscale
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark Salter
QA Contact: Jonathan Larmour
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-31 13:31 UTC by Lutz Jänicke
Modified: 2007-04-18 16:52 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-02 10:17:41 UTC


Attachments (Terms of Use)

Description Lutz Jänicke 2003-03-31 13:31:41 UTC
Description of problem:
The SDRAM size of the IXDP425 Evaluation Board is 128MByte instead of the
256MByte currently configured, see hal/arm/xscale/ixdp425/current/include/ixdp425.h:

#define SDRAM_SIZE                         0x10000000  // 256MB

Version-Release number of selected component (if applicable):
CVS

How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Mark Salter 2003-04-02 00:35:48 UTC
http://developer.intel.com/design/network/products/npfamily/ixdp425.htm
shows that the board has 256MB. My board has 256MB. Is there a 128MB
model? Are all four SDRAM positions populated on your board? In any
case, if there are 128MByte boards out there, some runtime code to size
memory would be nice. I can't do it, though as I don't have a 128MByte
board.

Comment 2 Lutz Jänicke 2003-04-02 10:17:41 UTC
I studied once more the documentation.
My value (128MB) was around since the very first preliminary software version we
received from Intel. This has long since been corrected but never made it to our
files.
256MB and therefore Redboot is correct.

Sorry for any confusion caused,
       Lutz


Note You need to log in before you can comment on or make changes to this bug.