Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 8761 - TFTP install boot on SPARCstation 1+ fails
Summary: TFTP install boot on SPARCstation 1+ fails
Status: CLOSED DUPLICATE of bug 3696
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: sparc
OS: Linux
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
: 9939 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2000-01-23 08:24 UTC by Bitt Faulk
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2000-04-17 17:33:53 UTC

Attachments (Terms of Use)

Description Bitt Faulk 2000-01-23 08:24:21 UTC
I have a SPARCstation 1+ that I am trying to install RedHat 6.1 on.  The
machine is "headless", meaning without a framebuffer or keyboard.  I am
booting and trying to install it via the serial port ttya.  I downloaded and
tried to tftp boot off of it.  The machine loads the image, to offset
130600, according to the Boot PROM, and then hangs there indefinitely, and
it seems to lock up hard.  Even a break sent to the serial port will not
pop it back out to the PROM monitor.

Here's the log of the boot:

<--- Capture --->
SPARCstation 1+, No keyboard.
ROM Rev. 1.3, 28 MB memory installed, Serial #12648430.
Ethernet address 8:0:20:c0:ff:ee, Host ID: 53c0ffee.


Type b (boot), c (continue), or n (new command mode)
Type  help  for more information
ok boot net
Booting from: le(0,0,0)
<--- Capture --->

The cursor is left on the same line as the block count, with a single space
after the count (underneath the space between "Booting" and "from:".

A tcpdump shows:

03:13:50.174129 rarp who-is 8:0:20:c0:ff:ee tell 8:0:20:c0:ff:ee
03:13:50.174160 rarp reply 8:0:20:c0:ff:ee at
03:13:50.199004 >
                23 RRQ "AC1000FE.SUN4C" (ttl 123, id 1234)
03:13:50.392473 >
       udp 516 (ttl 64, id 10461)
03:13:50.410964 >
       udp 4 (ttl 123, id 1234)
03:13:50.411564 >
       udp 516 (ttl 64, id 10462)

and then the tftp d/l continues for quite a while with no changes in the
pattern until the end:

03:14:47.648571 >
       udp 4 (ttl 123, id 1234)
03:14:47.648638 >
       udp 516 (ttl 64, id 12865)
03:14:47.672857 >
       udp 4 (ttl 123, id 1234)
03:14:47.672920 >
       udp 4 (ttl 64, id 12866)
03:14:47.687980 >
       udp 4 (ttl 123, id 1234)

and then it stops dead.

Again, I cannot break out to the 'ok' prompt; I have to power-cycle the
machine.  I have not been able to test it from a framebuffer, as I don't
have a 13W3 monitor or adapter available.  I have tried it with and without
a framebuffer installed.

Also, Debian slink seems to install fine, and the Solaris boot image boots,
but I don't have a Solaris machine on this subnet to perform an install

Comment 1 Bitt Faulk 2000-01-25 04:06:59 UTC
Also, I found a SCSI cdrom and attached that.  It now seems to be installing
fine off of the CD.  So there must be some sort of problem with the tftp boot
image specifically.

Comment 2 Bill Nottingham 2000-03-04 21:23:59 UTC
*** Bug 9939 has been marked as a duplicate of this bug. ***

Comment 3 Jeremy Katz 2000-07-14 05:01:39 UTC

*** This bug has been marked as a duplicate of 3696 ***

Note You need to log in before you can comment on or make changes to this bug.