Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87589 - xinetd uses 98% cpu
Summary: xinetd uses 98% cpu
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinetd
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-29 14:18 UTC by Bob Scharle
Modified: 2014-08-31 23:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-07 15:12:55 UTC


Attachments (Terms of Use)

Description Bob Scharle 2003-03-29 14:18:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011019
Netscape6/6.2

Description of problem:
xinetd uses 98% cpu
I did a cold install on a 2.4GHz P4 with 512 MB memory

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Cold install RH 8.0
2.login
3.run 'top'
    

Additional info:

Comment 1 Bob Scharle 2003-04-06 07:18:49 UTC
What is the status of this problem.  I can not run xinet thus rendering this
version of Red Hat unusable and therefore a waste of $175.00 which is a lot of
money.

Comment 2 Jay Fenlason 2003-04-08 21:28:02 UTC
WORKSFORME on all the machines I've tried: a dual P4xeon-2G, a celeron 500, and
an Athlon 750.  Since I can't reproduce it here, I'm not going to be able to
debug this without a lot of legwork on your part.

What is your network configuration like?  What packages did you install?  Do any
of your log files have any useful information in them?  What does "strace -p
(the pid of the xinetd process)" show?  Etc.

Comment 3 Bob Scharle 2003-04-09 01:54:44 UTC
I really don't have the time to debug your software.  It should not be be my
responsibility to debug your software.  I would very much like a refund since
your software does not work.  I did notice that there is another ticket with the
same problem.  I also find it very hard to believe that you can not reproduce
the same problem.  Please let me know what the procedures are to get a full
refund so that I can purchase another vendors version of Linux.

Comment 4 Bob Scharle 2003-04-14 23:55:08 UTC
What is the status of the bug?   What are the procedures for a refund on
software that does not work?  If you are unable to answer my questions please
forward me the name and email address of your manager.  I DO NOT want to hear it
works for me.  I either want this bug fixed or my money back.

Comment 5 Tim Burke 2003-04-15 13:33:07 UTC
It is common practice that in the course of diagnosing problems that we request
the customer provide us the information we need to go on.  This is not unique to
Linux, where the spirit of cooperation is supposed to be even stronger.

Please provide us more information to help us reproduce and address the problem
you are encountering.  What is your hardware configuration?  What are the
contents of your xinetd.d?  Given that the xinetd.d contents are generally
tailored per site, we would like to know how yours is configured.


Comment 6 Jay Fenlason 2003-04-17 19:48:47 UTC
Please download the xinetd-2.3.11-1.8.0.i386.rpm file avaliable at
ftp://people.redhat.com/~fenlason/.xinetd/xinetd-2.3.11-1.8.0.i386.rpm  Then
install it (as root) with the command "rpm -Fvh xinetd-2.3.11-1.8.0.i386.rpm"
after cd-ing to the directory where you downloaded the xinetd-2.3.11-1.8.0.i386.rpm

Comment 7 Bob Scharle 2003-04-18 21:35:48 UTC
When I double click on the link it fails with the following message:

Failed to change directory

I tried to ftp to people.redhat.com and cd into fenlason/xinetd and that also
does not work.

Comment 8 Jay Fenlason 2003-04-21 15:33:31 UTC
try:
ftp://people.redhat.com/fenlason/.xinetd/xinetd-2.3.11-1.8.0.i386.rpm
If that doesn't work, try
http://people.redhat.com/fenlason/.xinetd/xinetd-2.3.11-1.8.0.i386.rpm

Note the . in front of xinetd in the path--it's hard to see.



Comment 9 Bob Scharle 2003-04-25 18:02:34 UTC
I was able to download and install the xinetd from your web site and that seems
to have resolved the problem.  Thank you.

Comment 10 Jay Fenlason 2003-08-07 15:12:55 UTC
Closing this since the reporter says it is fixed.


Note You need to log in before you can comment on or make changes to this bug.