Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87588 - redhat-config-xfree uses ' 17" COLOR' as monitor name
Summary: redhat-config-xfree uses ' 17" COLOR' as monitor name
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhpl
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-29 10:22 UTC by Gerald Teschl
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version: 0.98.1-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-24 20:57:19 UTC


Attachments (Terms of Use)

Description Gerald Teschl 2003-03-29 10:22:37 UTC
I just tried to reconfigure x after replacing the vga card,
which failed. The Xserver complained about syntax errors in
the monitor section and inspection of the config file revealed the cause:

      ModelName    " 17" COLOR"

Indedd, '17" COLOR' is not a good choice for a monitor name;-)
Please grep your database for 17" and fix this.

Comment 1 Brent Fox 2003-04-01 17:49:54 UTC
I can't find that string in our monitor database anywhere.  See for yourself in
the /usr/share/hwdata/MonitorsDB file.  

Comment 2 Gerald Teschl 2003-04-01 18:18:39 UTC
OK. But how did it get there? Could it be that the monitor returned this
string when probed?

Comment 3 Brent Fox 2003-04-01 20:50:10 UTC
Quite possibly.  As root, run '/usr/sbin/ddcprobe' and see if the string is
returned by ddcprobe.

Comment 4 Gerald Teschl 2003-04-03 18:10:20 UTC
As I already suspected:

Monitor DDC probe results
ID: STC1712
Name:  17" COLOR
Horizontal Sync (kHZ): 30-95
Vertical Sync (HZ)  : 50-160
Width (mm): 320
Height(mm): 240

Always sanitize strings before you use them;-)

Comment 5 Brent Fox 2003-04-03 18:53:31 UTC
This monitor ID isn't in our monitors database.  This name '17" COLOR' is being
returned from the monitor hardware itself, so there's not much I can do about that.

However, if you'll tell me exactly what kind of monitor this is, I'll try to add
it to our database with a more meaningful name.

Comment 6 Gerald Teschl 2003-04-03 20:59:32 UTC
I am afraid I don't quite get it: Of course there is nothing you can do about the
name. But I feel you should not use the name returned by the probe as is.
Just remove all characters other than say letters, numbers, space from
the string returned by the probe before putting it into the config file.
There is no way one can predict what weird strings some crappy hardware
might return...

In the above case it will say "17 COLOR" in the config file, which does
not make to much sense, but it is better than a syntax error.

The monitor is what it claims to be, a 17" color monitor. The returned
frequencies are ok. I don't know the brand and I can't find out right
now, since I am in a different building.

Comment 7 Brent Fox 2003-04-03 21:14:29 UTC
If you provide me with the monitor information, I will add it to the MonitorsDB.
 Once the data is in there, the program will use the name it finds in the
database instead of what is returned from the monitor.  This will avoid the
syntax error.

Comment 8 Gerald Teschl 2003-04-11 19:45:12 UTC
This is a noname monitor: On the monitor it just says "Platin". On the
pack it says "B-712UDT" for the model and "SPTI" for the manufacturer.

However, I still feel it is better to strip any non sane character from
the string before putting it into XF86COnfig as a precaution, since
other monitors might return similar strings.

Comment 9 Brent Fox 2003-04-24 20:57:19 UTC
Ok, I've changed monitor.py in rhpl to strip '"' chars from probed monitor
strings.  It should be fixed in rhpl-0.98.1-2.


Note You need to log in before you can comment on or make changes to this bug.