Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87572 - libuser creates invalid links in home directory when links exist in /etc/skel
Summary: libuser creates invalid links in home directory when links exist in /etc/skel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libuser
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
: 98912 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-28 23:02 UTC by gLaNDix
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version: 0.51.10-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-02 22:20:40 UTC


Attachments (Terms of Use)
output from ls -l /home/test with symlinks in /etc/skel (deleted)
2003-03-28 23:04 UTC, gLaNDix
no flags Details
patch to fix libuser link problem (deleted)
2003-03-28 23:07 UTC, gLaNDix
no flags Details | Diff

Description gLaNDix 2003-03-28 23:02:42 UTC
Description of problem: 
If you create symbolic links in /etc/skel and run either luseradd or the 
redhat-config-users program to create a new user, the links are created in the 
new user's home directory, but point to invalid locations. 
 
 
 
Version-Release number of selected component (if applicable): 
all including rpm downloaded from phoebe-3 beta (also applies to libuser in 
mandrake 9.0) 
 
How reproducible: 
It happens with EVERY link EVERY time. 
 
Steps to Reproduce: 
1. cd /etc/skel 
2. touch test 
3. ln -s test test2 
4. /usr/sbin/lusradd testuser 
 
     
Actual results: 
 
 
Expected results: 
[root@localhost SPECS]# ls -l /home/testuser 
total 16 
lrwxrwxrwx    1 test2    test2        4095 Mar 26 16:14 test -> test2 
 
Additional info: 
This effects every version of libuser I have found in both Red Hat and 
Mandrake Linux.

Comment 1 gLaNDix 2003-03-28 23:04:54 UTC
Created attachment 90776 [details]
output from ls -l /home/test with symlinks in /etc/skel

Comment 2 gLaNDix 2003-03-28 23:07:31 UTC
Created attachment 90777 [details]
patch to fix libuser link problem

Comment 3 Crutcher Dunnavant 2003-04-09 16:30:02 UTC
Seen this one as well, bit me badly. Cost me 3 weeks of a class full of chemical
engineer's time. Please apply patch.

Comment 4 Miloslav Trmač 2004-09-02 15:10:46 UTC
*** Bug 98912 has been marked as a duplicate of this bug. ***

Comment 5 Miloslav Trmač 2004-09-02 22:20:40 UTC
Thanks for the patch.
Should be fixed in libuser-0.51.10-1, when it hits rawhide.


Note You need to log in before you can comment on or make changes to this bug.