Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87569 - wine crashes with error report message... GLIBC_2.0 not defined
Summary: wine crashes with error report message... GLIBC_2.0 not defined
Keywords:
Status: CLOSED DUPLICATE of bug 86437
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wine
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-28 22:12 UTC by Alessandro Volpi
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:23 UTC


Attachments (Terms of Use)

Description Alessandro Volpi 2003-03-28 22:12:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
After having installed wine from the distribution CD I tried to run some Windows
simple applications. Independently from the application I always get the same
message. For example, when I try to run the MS accessories calculator I get :

[root@Ws1L exch]# wine ./calc.exe
wine: relocation error: /usr/lib/wine/libntdll.dll.so: symbol __fork, version
GLIBC_2.0 not defined in file libc.so.6 with link time reference

I looked for the file /lib/libc.so.6 and I found that it is a link to
/lib/libc-2.3.2.so . I also found a link and a file with the same names in
/lib/i686 .

Version-Release number of selected component (if applicable):
wine-20020605-2

How reproducible:
Always

Steps to Reproduce:
1.copy the foo.exe windows executable to the current directory
2.issue the command wine ./foo.exe
3.

Actual Results:  The following error message is displayed in the Konsole terminal

wine: relocation error: /usr/lib/wine/libntdll.dll.so: symbol __fork, version
GLIBC_2.0 not defined in file libc.so.6 with link time reference

Expected Results:  The windows application should have been started.

Additional info:

The libc in my RH 8.0 system is fullu updated using the up2date application

Comment 1 R.K.Aa. 2003-03-29 04:54:13 UTC
this is a duplicate of bug 86437

Comment 2 Thomas Woerner 2003-03-31 13:28:33 UTC

*** This bug has been marked as a duplicate of 86437 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:52:23 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.