Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87488 - binary pgp file (ie not ascii armored text) interpreted as text
Summary: binary pgp file (ie not ascii armored text) interpreted as text
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-mime-data
Version: 9
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-27 16:23 UTC by Philip Long
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-12-09 21:35:33 UTC


Attachments (Terms of Use)

Description Philip Long 2003-03-27 16:23:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030221

Description of problem:
I filed this with ximian, and they gave their response below ...


This problem manifests itself starkly under evolution.

Evolution treats arriving file (EmergencyAlternate.doc.pgp) as MIME type 
"plain text document". It is not  ascii armored.  Saving the encrypted file
to disk mangles it in such a way that neither gpg (nor pgp) can then decrypt it.

Steps to reproduce the problem:
1. Receive encrypted file with .pgp extension
2. Notice evolution believes that it is plain text though it is not
3. Save to disk

Actual Results:

Corrupted file on disk


Expected Results:

Uncorrupted file on disk

How often does this happen? 

Corruption occurs when I received an X.doc.pgp but not when I received a
Test.txt.pgp

Additional Information:

The mozilla mailer is able to save the file off the IMAP server without
corruption.

A file named EmeAlt.doc.pgp does download correctly.

I have _no clue_ how to tell gnome how to interpert the data.  The control
center file types didn't let me do more than add .gpg to the mime type and let
gpg handle the data. (After which evolution asked if I wanted to launch gpg to
handle EmeAlt.doc.gpg, the one that was correctly detected.


------- Additional Comments From Jeff Stedfast 2003-03-20 16:29 -------

the problem is gnome-vfs is misdetecting the mime type likely. if we
get an attachment that is text/plain, we do charset conversions on it.

I don't feel this is a evolution bug. add mime type info to your
database so that those files are detected as application/octet-stream
rather than text/plain (since they aren't text/plain)

Version-Release number of selected component (if applicable):
2.2.0-1

How reproducible:
Sometimes

Steps to Reproduce:
1. See above
2.
3.
    

Actual Results:  See above

Expected Results:  See Above

Additional info:

See Above

Comment 1 Havoc Pennington 2003-03-27 21:28:58 UTC
Needs to be reported to bugzilla.gnome.org probably.

Comment 2 Bastien Nocera 2003-12-09 21:35:33 UTC
Closed upstream, closing here as well.
The reporter failed to give a file that would show such a problem.


Note You need to log in before you can comment on or make changes to this bug.