Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87485 - CDL inference engine not intelligent when selecting a CDL interface
Summary: CDL inference engine not intelligent when selecting a CDL interface
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: eCos
Classification: Retired
Component: CDL
Version: CVS
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bart Veer
QA Contact: Bart Veer
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-27 16:02 UTC by John Dallaway
Modified: 2007-03-27 04:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-20 16:23:21 UTC


Attachments (Terms of Use)

Description John Dallaway 2003-03-27 16:02:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
The CDL inference engine does not appear to select a CDL interface intelligently to satisfy a "requires one CDL interface" constraint. Sometimes, the selection of one particular CDL interface would result in fewer remaining conflicts than selecting another.

Version-Release number of selected component (if applicable):
AnonCVS

How reproducible:
Always

Steps to Reproduce:
1. Select the Integrator ARM966 platform template in the eCos configtool
2. Observe the list of conflicts and suggested solutions

    

Actual Results:  The suggested solution for "CYGPKG_HAL_ARM_ARM9_VARIANT - Unsatisfied - Requires 1 == CYGINT_HAL_ARM_ARM9_VARIANT" is to enable CYGPKG_HAL_ARM_ARM9_ARM920T


Expected Results:  The suggested solution for "CYGPKG_HAL_ARM_ARM9_VARIANT - Unsatisfied - Requires 1 == CYGINT_HAL_ARM_ARM9_VARIANT" should be to enable CYGPKG_HAL_ARM_ARM9_ARM966E since this would result in fewer conflicts overall.

Additional info:

Comment 1 Alex Schuilenburg 2003-06-20 16:23:21 UTC
This bug has moved to http://bugs.ecos.sourceware.org/show_bug.cgi?id=87485


Note You need to log in before you can comment on or make changes to this bug.