Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87483 - logwatch behaves on my "cgs-new" host.
Summary: logwatch behaves on my "cgs-new" host.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: logwatch
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-27 15:55 UTC by Zoran Dzelajlija
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version: 4.3.2-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-10 17:15:37 UTC


Attachments (Terms of Use)

Description Zoran Dzelajlija 2003-03-27 15:55:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913
Debian/1.2.6-2

Description of problem:
logwatch dumps all of the entries from /var/log/cron into my admin
mailbox.  Upon closer inspection, I found this regexp in
/etc/log.d/scripts/services/cron:

"s/^... .. ..:..:.. \w+ \w+\[\d+\]: \((\S+)\)\s+//"

This fails on my computer because the first \w doesn't match the "-" sign in my
hostname.  Replacing it with [\w-] is also incorrect (but works for me :-)
because, AFAIR, DNS documentation says host names should comprise of
[a-zA-Z0-9-] (note no underscore).  So the correct
regex would probably have [a-zA-Z0-9-]+ instead of the first \w.

Regards,
Zoran Dzelajlija

Version-Release number of selected component (if applicable):
logwatch-4.3.1-2

How reproducible:
Always

Steps to Reproduce:
1.set the hostname to something with - .
2.let some cron jobs trickle into the log
3.run /etc/cron.d/00-logwatch


Additional info:


Note You need to log in before you can comment on or make changes to this bug.