Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87480 - binaries do not use /lib/i686 after installing glibc-2.3.2-4.80.i686.rpm
Summary: binaries do not use /lib/i686 after installing glibc-2.3.2-4.80.i686.rpm
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 8.0
Hardware: i686
OS: Linux
high
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-27 15:32 UTC by Sandor Szabo
Modified: 2016-11-24 15:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-22 08:23:43 UTC


Attachments (Terms of Use)

Description Sandor Szabo 2003-03-27 15:32:35 UTC
Description of problem:
After installing glibc-2.3.2-4.80.i686.rpm binaries do not use the libraries in 
the directory /lib/i686 
Our binaries use the capabilities provided in the 
/lib/i686/libpthread-0.10.so and  does not work with /lib/libpthread.so.0

Version-Release number of selected component (if applicable):
glibc-2.3.2-4.80

How reproducible:
Before installing glibc-2.3.2-4.80.i686.rpm 

bash-2.05$ ldd a.out
        libpthread.so.0 => /lib/i686/libpthread.so.0 (0x40021000)
        libc.so.6 => /lib/i686/libc.so.6 (0x40036000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

After  installing glibc-2.3.2-4.80.i686.rpm 

-bash-2.05b$ ldd a.out
        libpthread.so.0 => /lib/libpthread.so.0 (0x40021000)
        libc.so.6 => /lib/libc.so.6 (0x40074000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

Steps to Reproduce:
1.ldd a.out 
2.install  glibc-2.3.2-4.80.i686.rpm 
3.ldd a.out 
    
Actual results:
libpthread is NOT used from /lib/i686

Expected results:
libpthread is used from /lib/i686


Additional info:
We depend on the i686 version of the libpthread library

Comment 1 Jakub Jelinek 2003-03-27 22:00:13 UTC
A bug in platform handling was fixed in glibc, unfortunately kernel in 8.0
is broken and doesn't supply proper value for AT_PLATFORM in ELF aux vector.
Please try ftp://people.redhat.com/jakub/glibc/errata/8.0/
which has the glibc fix backed out.

Comment 2 Sandor Szabo 2003-03-28 12:32:13 UTC
Hi Jakub,
I have downloaded the new patches from
ftp://people.redhat.com/jakub/glibc/errata/8.0/
but unfortunately the same behavior
Sorry, I still need you help

Comment 3 Michael Lee Yohe 2003-03-28 15:20:41 UTC
Wow.. I consider this a pretty big problem for those who rely on the performance
benefits of a properly targeted glibc.  Jakub - any idea if this warrants a
newly issued errata package (considering the amount of havoc the last update
seems to have created...)?

Comment 4 Jakub Jelinek 2003-03-29 08:45:35 UTC
Oops, sorry. There were more things needed to make /lib/i686 work
on a buggy kernel.
ftp://people.redhat.com/jakub/glibc/errata/8.0/*4.80.3*
already uses /lib/i686 on the current 8.0 errata kernel, and unlike 2.2.93-5
even searches /lib/i686 with LD_LIBRARY_PATH=/lib

Comment 5 Sandor Szabo 2003-03-31 09:43:57 UTC
Hi Jakub,
I have some good news! Your latest version works as expected.
We did test it with our software and it works.
Thanks for your help. 
When will this fix be available through errata?



Comment 6 Sandor Szabo 2003-03-31 09:49:40 UTC
Sorry I did not want to close it!

Comment 7 Michael Lee Yohe 2003-03-31 15:17:42 UTC
Has there been a kernel bug filed to track the problems that have caused
"unnecessary" hacks to get glibc to properly work with the Red Hat kernel?

Comment 8 Ulrich Drepper 2003-04-22 08:23:43 UTC
RHL9 (and RHL8 with the latest updates of glibc and kernel) shouldn't have any
problems.


Note You need to log in before you can comment on or make changes to this bug.