Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87479 - [RFE]include dependant service/package info in errata
Summary: [RFE]include dependant service/package info in errata
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Other
Version: RHN Stable
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: rhn-dev-list
QA Contact: Red Hat Network Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-27 15:18 UTC by Alan Fitzgerald
Modified: 2011-07-07 18:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-07 18:40:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alan Fitzgerald 2003-03-27 15:18:32 UTC
Description of problem:
It would be very useful if the errata reports gave a listing of possible 
services that would be dependant on the updated packages.  Or packages that 
are dependant on these new packages.  I know people have trouble figuring out 
what needs to be restarted after an update.  I think this would help relieve 
the uncertainty that leads to a lot of needless restarts.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Receive a RHN errata
2.Stare at it a while and relize, I guess I should just restart the machine
3.
    

Actual Results:  Everything works.  But this is such overkill.

Expected Results:  I would restart 1 or 2 services and be sadisfied my system 
was secure and know that the uses of this box were not inconvenienced.

Additional info:

Comment 1 Chip Turner 2003-04-14 15:40:37 UTC
reassigning to mjc since this is a text/process change in the errata system

Comment 2 Mark J. Cox 2003-04-14 15:59:46 UTC
We definately need to be more consistant with the messaging of what services
are affected by a change and what needs restarting.  We're already working on
documentation for the next security guide update that explains how to work out
when to restart, and i'll see how we can add it into the errata process.  In the
meantime this is a good resource:

http://www.hackinglinuxexposed.com/articles/20030409.html



Note You need to log in before you can comment on or make changes to this bug.