Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87473 - tmpwatch doesn't delete hidden .dotfiles
Summary: tmpwatch doesn't delete hidden .dotfiles
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tmpwatch
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-27 11:59 UTC by Boris Folgmann
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-13 20:43:10 UTC


Attachments (Terms of Use)

Description Boris Folgmann 2003-03-27 11:59:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.2; MultiZilla v1.1.32
final) Gecko/20030313

Description of problem:
I've got a lot of very old files like .famZaq7p3 lying around in my /tmp because
tmpwatch seems not to clean any hidden file that begins with a dot.


Version-Release number of selected component (if applicable):
tmpwatch-2.8.4-3

How reproducible:
Always

Steps to Reproduce:
1. generate an "old" hidden dotfile in /tmp
2. run tmpwatch on /tmp
    

Actual Results:  dotfiles still present in /tmp
tmpwatch -t shows that they are not scanned


Expected Results:  delete really all old files


Additional info:

Comment 1 Boris Folgmann 2003-06-05 14:13:35 UTC
Any chances for a fix?


Comment 2 Miloslav Trmač 2004-08-13 20:43:10 UTC
Works for me with tmpwatch-2.9.0-2.1:


$ mkdir z
$ touch -a -d '2 hours ago' z/.dotfile
$ /usr/sbin/tmpwatch -vvv 1 z
grace period is 3600
cleaning up directory z
found directory entry .dotfile
taking as significant time: Fri Aug 13 20:41:45 2004
 
removing file z/.dotfile


If the file in question is a socket (which it is), this would be a
duplicate of bug 66148.

Comment 3 Boris Folgmann 2004-08-14 15:07:55 UTC
I can't access this socket bug report. Why?


Comment 4 Miloslav Trmač 2004-08-14 20:43:05 UTC
See bug 114969 for the summary.


Note You need to log in before you can comment on or make changes to this bug.