Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87459 - Squirrlemail cannot login to uw-imap-2002b-5 by default
Summary: Squirrlemail cannot login to uw-imap-2002b-5 by default
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: squirrelmail
Version: 1.0
Hardware: noarch
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gary Benson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-27 03:04 UTC by Rick Johnson
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-01-08 11:08:56 UTC


Attachments (Terms of Use)

Description Rick Johnson 2003-03-27 03:04:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; YComp 5.0.0.0)

Description of problem:
Latest RawHide imap-2002b-5 doesn't allow "LOGIN" authentication method by 
default. This breaks SquirrleMail since it relies on plaintext LOGIN method. 
SquirrelMail at present only supports using stunnel for IMAPS implementation.

Version-Release number of selected component (if applicable):
1.2.10-4

How reproducible:
Always

Steps to Reproduce:
1. Install Squirrlemail 1.2.10-4
2. Install imap-2002b-5
3. Login to imap server via Squirrlemail.
    

Actual Results:  Login rejected - Squirrlemail doesn't support STARTTLS or 
alternate Plaintext Login methods

Expected Results:  Successful login.

Additional info:

Changing IMAP to use SSLTYPE=unix instead of SSLTYPE=unix.nopwd via spec fixes 
the issue (but breaks IESG security requirement of disabling plaintext w/o 
STARTTLS)

Filing here because the imap change is "better" as long as SquirrelMail is 
capable of using STARTTLS or an alternate login method.

Comment 1 Rick Johnson 2003-04-03 22:47:35 UTC
Squirrelmail 1.4.0 when combined with PHP 4.3.0 or higher will support TLS
authentication.


Note You need to log in before you can comment on or make changes to this bug.