Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87427 - Adding a new Content Type causes CCM Error
Summary: Adding a new Content Type causes CCM Error
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bryan Che
QA Contact: Jon Orris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-26 20:36 UTC by Jon Orris
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-24 15:20:42 UTC


Attachments (Terms of Use)

Description Jon Orris 2003-03-26 20:36:36 UTC
@28953
Description of problem:
Clicking 'Add Content Type' link in Content Center/Content Types causes a CCM
Error. Appears to be bad sql

-*-*-*-*-*- Begin Error Report -*-*-*-*-*-
-*-*-*- ACS Error Report Code:
goodeats.boston.redhat.com:8080:45c70d11:f42c08749e -*-*-*-
-*-*-*- Message: Error executing SQL: 
select *
from (select t.type_id,
             t.object_type,
             t.label,
             t.description,
             t.classname,
             t.is_internal,
             t.item_form_id
      from content_types t
      where not exists (select 1 content_section_type_map m
                        where m.section_id=?
                        and t.type_id=m.type_id)) results
where ((is_internal='0')) (root cause: ERROR:  parser: parse error at or near
"content_section_type_map"
) -*-*-*-

-*-*-*- Section: HTTP headers -*-*-*-
Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, */*
Accept-Encoding: gzip, deflate
Accept-Language: en-us
Connection: Keep-Alive
Cookie: JSESSIONID=ah3AxY_hn6Gd;
ad_user_login=7075!1048711682193!LJP4rPxc0f6IlWCzfBZGwg==
Host: goodeats.boston.redhat.com:8080
Referer:
http://goodeats.boston.redhat.com:8080/ccm/articles/admin/index.jsp?bbp.714.state=+1054+&bbp.450.sel=4003&bbp.892.d=asc&bbp.432.sel=6003&bbp.10.folder=1016&query=newuser@cms.com&bbp.714.cc=1054&bbp.v=7&bbp.s=9&bbp.9.pane=4&bbp.85.ps=20&bbp.i=659j00y4kj7h2sgldkuvd3dyiq1j8fm9wwj4ivbc2v27vnbqryj8mvbfilb2rwzy5l8cefp17q3lgkvxuryfbbrl36qk8miymrsfmx38e1o2m1rcbgg4afpq5waixhwdotzf5o2x2aa8va03z5wwra5zcqub3n9o06bsf18g&bbp.e=select&g11n.enc=ISO-8859-1
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

-*-*-*- Section: Cookies -*-*-*-
JSESSIONID: ah3AxY_hn6Gd (expires: -1)
ad_user_login: 7075!1048711682193!LJP4rPxc0f6IlWCzfBZGwg== (expires: -1)

-*-*-*- Section: CCM User -*-*-*-
Party not logged in

-*-*-*- Section: Stack trace -*-*-*-
com.arsdigita.persistence.PersistenceException: Error executing SQL: 
select *
from (select t.type_id,
             t.object_type,
             t.label,
             t.description,
             t.classname,
             t.is_internal,
             t.item_form_id
      from content_types t
      where not exists (select 1 content_section_type_map m
                        where m.section_id=?
                        and t.type_id=m.type_id)) results
where ((is_internal='0')) (root cause: java.sql.SQLException: ERROR:  parser:
parse error at or near "content_section_type_map"
)
	at
com.arsdigita.persistence.PersistenceException.newInstance(PersistenceException.java:128)
	at com.arsdigita.persistence.DataStore.fireOperation(DataStore.java(Compiled Code))
	at
com.arsdigita.persistence.DataQueryImpl.executeQuery(DataQueryImpl.java(Compiled
Code))
	at
com.arsdigita.persistence.DataQueryImpl.executeQuery(DataQueryImpl.java(Compiled
Code))
	at
com.arsdigita.persistence.DataAssociationCursorImpl.executeQuery(DataAssociationCursorImpl.java:135)
	at
com.arsdigita.persistence.DataQueryImpl.checkResultSet(DataQueryImpl.java(Compiled
Code))
	at com.arsdigita.persistence.DataQueryImpl.isEmpty(DataQueryImpl.java:352)
	at
com.arsdigita.persistence.DataAssociationImpl.isEmpty(DataAssociationImpl.java:507)
	at com.arsdigita.domain.DomainQuery.isEmpty(DomainQuery.java:156)
	at
com.arsdigita.cms.ui.type.AdministrationPane.actionPerformed(AdministrationPane.java:242)
	at com.arsdigita.bebop.ControlLink.fireActionEvent(ControlLink.java:146)
	at com.arsdigita.bebop.ToggleLink.respond(ToggleLink.java:121)
	at com.arsdigita.bebop.PageState.respond(PageState.java:348)
	at com.arsdigita.bebop.Page.process(Page.java:696)
	at com.arsdigita.bebop.Page.process(Page.java:678)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:732)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:222)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:72)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:228)
	at com.arsdigita.cms.dispatcher.CMSDispatcher.dispatch(CMSDispatcher.java:230)
	at
com.arsdigita.cms.dispatcher.CMSDispatcher.chainedDispatch(CMSDispatcher.java:307)
	at com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
	at
com.arsdigita.cms.dispatcher.ContentSectionDispatcher.dispatch(ContentSectionDispatcher.java:66)
	at
com.arsdigita.sitenode.SiteNodeDispatcher.doDispatch(SiteNodeDispatcher.java:413)
	at com.arsdigita.sitenode.SiteNodeDispatcher.access$100(SiteNodeDispatcher.java:71)
	at com.arsdigita.sitenode.SiteNodeDispatcher$1.excurse(SiteNodeDispatcher.java:248)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.sitenode.SiteNodeDispatcher.dispatch(SiteNodeDispatcher.java:235)
	at
com.arsdigita.dispatcher.BaseDispatcherServlet.service(BaseDispatcherServlet.java:315)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.QNamedDispatcher.forward(QNamedDispatcher.java:157)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:203)
	at com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:150)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.CacheInvocation.service(CacheInvocation.java:135)
	at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:221)
	at com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:163)
	at com.caucho.server.TcpConnection.run(TcpConnection.java:137)
	at java.lang.Thread.run(Thread.java:512)
Root cause: 
java.sql.SQLException: ERROR:  parser: parse error at or near
"content_section_type_map"

	at org.postgresql.core.QueryExecutor.execute(QueryExecutor.java(Compiled Code))
	at org.postgresql.jdbc2.Statement.execute(Statement.java(Compiled Code))
	at org.postgresql.jdbc2.Statement.execute(Statement.java(Compiled Code))
	at
org.postgresql.jdbc2.PreparedStatement.execute(PreparedStatement.java(Compiled
Code))
	at com.arsdigita.db.PreparedStatement.doExecute(PreparedStatement.java(Compiled
Code))
	at com.arsdigita.db.PreparedStatement.execute(PreparedStatement.java(Compiled
Code))
	at com.arsdigita.persistence.DataStore.fireOperation(DataStore.java(Compiled Code))
	at
com.arsdigita.persistence.DataQueryImpl.executeQuery(DataQueryImpl.java(Compiled
Code))
	at
com.arsdigita.persistence.DataQueryImpl.executeQuery(DataQueryImpl.java(Compiled
Code))
	at
com.arsdigita.persistence.DataAssociationCursorImpl.executeQuery(DataAssociationCursorImpl.java:135)
	at
com.arsdigita.persistence.DataQueryImpl.checkResultSet(DataQueryImpl.java(Compiled
Code))
	at com.arsdigita.persistence.DataQueryImpl.isEmpty(DataQueryImpl.java:352)
	at
com.arsdigita.persistence.DataAssociationImpl.isEmpty(DataAssociationImpl.java:507)
	at com.arsdigita.domain.DomainQuery.isEmpty(DomainQuery.java:156)
	at
com.arsdigita.cms.ui.type.AdministrationPane.actionPerformed(AdministrationPane.java:242)
	at com.arsdigita.bebop.ControlLink.fireActionEvent(ControlLink.java:146)
	at com.arsdigita.bebop.ToggleLink.respond(ToggleLink.java:121)
	at com.arsdigita.bebop.PageState.respond(PageState.java:348)
	at com.arsdigita.bebop.Page.process(Page.java:696)
	at com.arsdigita.bebop.Page.process(Page.java:678)
	at com.arsdigita.bebop.Page.buildDocument(Page.java:732)
	at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:222)
	at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:72)
	at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:228)
	at com.arsdigita.cms.dispatcher.CMSDispatcher.dispatch(CMSDispatcher.java:230)
	at
com.arsdigita.cms.dispatcher.CMSDispatcher.chainedDispatch(CMSDispatcher.java:307)
	at com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
	at
com.arsdigita.cms.dispatcher.ContentSectionDispatcher.dispatch(ContentSectionDispatcher.java:66)
	at
com.arsdigita.sitenode.SiteNodeDispatcher.doDispatch(SiteNodeDispatcher.java:413)
	at com.arsdigita.sitenode.SiteNodeDispatcher.access$100(SiteNodeDispatcher.java:71)
	at com.arsdigita.sitenode.SiteNodeDispatcher$1.excurse(SiteNodeDispatcher.java:248)
	at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
	at com.arsdigita.sitenode.SiteNodeDispatcher.dispatch(SiteNodeDispatcher.java:235)
	at
com.arsdigita.dispatcher.BaseDispatcherServlet.service(BaseDispatcherServlet.java:315)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.QNamedDispatcher.forward(QNamedDispatcher.java:157)
	at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:203)
	at com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:150)
	at com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
	at com.caucho.server.http.Invocation.service(Invocation.java:312)
	at com.caucho.server.http.CacheInvocation.service(CacheInvocation.java:135)
	at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:221)
	at com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:163)
	at com.caucho.server.TcpConnection.run(TcpConnection.java:137)
	at java.lang.Thread.run(Thread.java:512)


-*-*-*- Section: Request summary -*-*-*-
Context path: 
Request URI: /ccm/articles/admin/index.jsp
Query string:
bbp.714.state=+1054+&bbp.450.sel=4003&bbp.892.d=asc&bbp.432.sel=6003&bbp.823.sel=7053&bbp.10.folder=1016&query=newuser%40cms.com&bbp.714.cc=1054&bbp.v=1&bbp.s=824&bbp.9.pane=7&bbp.85.ps=20&bbp.i=8oxp2n8ezze79c3d9zx803isze3g0an6dpq8skpntkbj0sye8cem2xv23qfyzmnlhs5iu1sahjze7z0ncratkjfattzfscc19i7zv4jvlnidzspjy1a7epk3x5mt8cpzdgr2z9iqf9x8sr8fh9pt3562mvbjvya7m1hc2c7nk00&bbp.e=toggle&g11n.enc=ISO-8859-1
Method: GET
Remote user: null

-*-*-*- Section: System properties -*-*-*-
file.encoding: UTF-8
file.encoding.pkg: sun.io
file.separator: /
invokedviajava: 
java.assistive: ON
java.awt.fonts: 
java.awt.graphicsenv: sun.awt.X11GraphicsEnvironment
java.awt.printerjob: sun.awt.motif.PSPrinterJob
java.class.path:
/home/boston/jorris/dev/lib/classes12.zip:/home/boston/jorris/dev/lib/junit.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/resin.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/jdbc2_0-stdext.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/jta-spec1_0_1.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/jndi.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/dom.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/sax.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/jaxp.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/jmx.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/webutil.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/jdbc-mysql.jar:/opt/IBMJava2-131/lib/tools.jar:/opt/IBMJava2-131/jre/lib/rt.jar:/home/boston/jorris/webserver/resin-2.1.4/lib/jsdk23.jar
java.class.version: 46.0
java.compiler: jitc
java.ext.dirs: /opt/IBMJava2-131/jre/lib/ext
java.fullversion: J2RE 1.3.1 IBM build cxia32131-20020410 (JIT enabled: jitc)
java.home: /opt/IBMJava2-131/jre
java.io.tmpdir: /tmp
java.library.path:
/opt/IBMJava2-131/jre/bin:/opt/IBMJava2-131/jre/bin/classic:/product/9.2.0.1/lib:/product/9.2.0.1/ctx/lib:/product/9.2.0.1/JRE/lib/i386/native_threads:/lib:/usr/lib:libexec:/usr/lib
java.naming.factory.initial: com.caucho.naming.InitialContextFactoryImpl
java.naming.factory.url.pkgs: com.caucho.naming
java.runtime.name: Java(TM) 2 Runtime Environment, Standard Edition
java.runtime.version: 1.3.1
java.specification.name: Java Platform API Specification
java.specification.vendor: Sun Microsystems Inc.
java.specification.version: 1.3
java.vendor: IBM Corporation
java.vendor.url: http://www.ibm.com/
java.vendor.url.bug: 
java.version: 1.3.1
java.vm.info: J2RE 1.3.1 IBM build cxia32131-20020410 (JIT enabled: jitc)
java.vm.name: Classic VM
java.vm.specification.name: Java Virtual Machine Specification
java.vm.specification.vendor: Sun Microsystems Inc.
java.vm.specification.version: 1.0
java.vm.vendor: IBM Corporation
java.vm.version: 1.3.1
javax.xml.parsers.DocumentBuilderFactory:
org.apache.xerces.jaxp.DocumentBuilderFactoryImpl
javax.xml.parsers.SAXParserFactory: org.apache.xerces.jaxp.SAXParserFactoryImpl
javax.xml.transform.TransformerFactory:
org.apache.xalan.processor.TransformerFactoryImpl
line.separator: 

org.xml.sax.driver: org.apache.xerces.parsers.SAXParser
os.arch: x86
os.name: Linux
os.version: 2.4.18-27.8.0
path.separator: :
PreferredXSLTTransformer: XALAN
resin.home: /home/boston/jorris/webserver/resin-2.1.4
sun.boot.class.path:
/opt/IBMJava2-131/jre/lib/rt.jar:/opt/IBMJava2-131/jre/lib/i18n.jar:/opt/IBMJava2-131/jre/classes
sun.boot.library.path: /opt/IBMJava2-131/jre/bin
sun.io.unicode.encoding: UnicodeLittle
user.dir: /home/boston/jorris/webserver/resin-2.1.4
user.home: /home/boston/jorris
user.language: en
user.name: jorris
user.region: US
user.timezone: America/New_York
vendor: Apache Software Foundation
vendor-url: http://xml.apache.org/xalan
version: 2.1.0
-*-*-*-*-*- End Error Report -*-*-*-*-*-

Comment 1 Bryan Che 2003-03-26 20:57:58 UTC
fixed at changelist 28967

Comment 2 Bryan Che 2003-03-26 21:00:01 UTC
fixed at changelist 28967


Note You need to log in before you can comment on or make changes to this bug.