Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87405 - Segmentation fault in 'updatedb' from cron
Summary: Segmentation fault in 'updatedb' from cron
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: slocate
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-26 18:05 UTC by Michal Jaegermann
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-15 18:47:13 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2003-03-26 18:05:02 UTC
Description of problem:

On one (Athlon) machine I see recently pretty consistently these:

/etc/cron.daily/slocate.cron: line 3:  9934 Segmentation fault
/usr/bin/updatedb -f "nfs,smbfs,ncpfs,proc,devpts" -e
"/tmp,/var/tmp,/usr/tmp,/afs,/net"

mailed by cron.  I _think_ that this really coincides with a recent
update to kernel-2.4.18-27.7.x.

In /etc/cron.daily/slocate.cron I commented out
"renice +19 -p $$ >/dev/null 2>&1" line and this appears to help.
At least I did not a message like above from the last night where
they were otherwise a fixture.

Version-Release number of selected component (if applicable):
slocate-2.6-1

How reproducible:
I do not observe that on other machines which are somewhat related
both hardware-wise and software-wise.  A different memory layout?

Comment 1 Boris Folgmann 2003-10-20 17:59:04 UTC
Today I received a similar mail from my cron daemon.

/etc/cron.daily/slocate.cron:

/etc/cron.daily/slocate.cron: line 3:  7209 Segmentation fault     
/usr/bin/updatedb -f "nfs,smbfs,ncpfs,proc,devpts" -e
"/tmp,/var/tmp,/usr/tmp,/afs,/net"
/usr/bin/run-parts: line 36:  7275 Segmentation fault      $i 2>&1
      7276                       | awk -v "progname=$i" 'progname {
				   print progname ":\n"
				   progname="";
			       }
			       { print; }'
/usr/bin/run-parts: line 36:  7444 Done                    $i 2>&1
      7445 Segmentation fault      | awk -v "progname=$i" 'progname {
				   print progname ":\n"
				   progname="";
			       }
			       { print; }'

It's slocate-2.6-8 on a RH9 system with kernel 2.4.20-20.9.


Comment 2 Thomas Woerner 2004-10-15 18:47:13 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.



Note You need to log in before you can comment on or make changes to this bug.