Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 87396 - gnome-terminal doesn't handle clear to end of screen properly
Summary: gnome-terminal doesn't handle clear to end of screen properly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vte
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-26 16:46 UTC by Gilles Detillieux
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-11-05 03:05:52 UTC


Attachments (Terms of Use)

Description Gilles Detillieux 2003-03-26 16:46:50 UTC
Description of problem:
When doing a clear to EOS operation (Esc [ J), gnome-terminal doesn't do it
properly like xterm and other ANSI-compliant terminal emulators.  It should
clear from the current cursor position to the end of the line, and all lines
below it, but leave any text left of or above the cursor intact.  What it does
is clear all text on or below the line where the cursor is, so text left of
the cursor is wiped out.

Version-Release number of selected component (if applicable):
2.0.1-5

How reproducible:
Try outputting an Esc-[-J sequence with the cursor somewhere in the middle
of the line, in both xterm and gnome-terminal and note the difference.

Steps to Reproduce:
1. In gnome-terminal, at the shell prompt, type: echo -e 'xxxx\033[Jyyyy'
2. Note the output: "    yyyy", not "xxxxyyyy".
3. Try again in xterm, and note it leaves "xxxxyyyy" on the screen.
    
Actual results:
    yyyy

Expected results:
xxxxyyyy

Additional info:

Comment 1 Gilles Detillieux 2003-04-11 22:14:15 UTC
This was a problem with vte-0.8.19-2.

It seems to be fixed in vte-0.10.25-1 under Red Hat 9,
as are a few other problems that were reported for vte 0.8,
but it sure would be nice to have a backport of vte-0.10.25-1
for Red Hat 8.0.  It seems that would require also updating
gnome-terminal and any other packages that depend on vte, as
the shared library version number for libvte.so jumped from
2 to 4.


Note You need to log in before you can comment on or make changes to this bug.