Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 8724 - broken -c and -w options
Summary: broken -c and -w options
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netkit-base
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL: http://sublogic.com/rpms/
Whiteboard:
: 6160 6254 6262 7264 7785 13211 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-21 19:38 UTC by James Manning
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-27 19:39:54 UTC


Attachments (Terms of Use)

Description James Manning 2000-01-21 19:38:15 UTC
The -c and -w options failed both when -f (flood) was used and
when a host was down (but no ICMP error packets were getting
returned from routers) due to their logic checking placement
in the for(;;) loop of the program.  The "optcw" patch in the
src.rpm fixes this.

Also, -w was broken by checking time passed > time to run
so it would always run 1 second longer than requested,
and the "deadline" patch fixes this by changing it to >=

Both the .src.rpm and .i386.rpm are available at
http://sublogic.com/rpms/ with the above two patches and
two simple %changelog entries for them, nothing else.

-38 fixed the logic placement for the options but didn't
catch the -w problem, -39 (available at the url) adds
this fix.

The -c option fix has been sent to the netkit-base maintainers
against their 0.16 which doesn't include a -w option.

Comment 1 Jeff Johnson 2000-01-27 19:39:59 UTC
Fixed in iputils-991024-2 from Raw Hide. The optcw patch was already
part of the sources, and I've added the deadline patch.

Thanks for the patches.

Comment 2 Jeff Johnson 2000-01-27 20:04:59 UTC
*** Bug 6160 has been marked as a duplicate of this bug. ***

Comment 3 Jeff Johnson 2000-01-27 20:05:59 UTC
*** Bug 6254 has been marked as a duplicate of this bug. ****** Bug 6262 has been marked as a duplicate of this bug. ***

Comment 4 Jeff Johnson 2000-01-27 20:06:59 UTC
*** Bug 7785 has been marked as a duplicate of this bug. ***

Comment 5 Jeff Johnson 2000-01-27 20:07:59 UTC
*** Bug 7264 has been marked as a duplicate of this bug. ***

Comment 6 agyorgi 2000-02-26 07:00:59 UTC
The updated netkit-base (netkit-base-0.10-39.i386.rpm) for Red Hat Linux 6.1
from "http://sublogic.com/rpms/" fixes the ping -c switch, but still it does not
fix the exit status... the ping executable enclosed in the updated netkit-base
always returns 0 whether the ping is successful or not (tested this for both
the local network segment and an external site)... I have updated my iputils
package from Red Hat's Rawhide ftp site to iputils-991024-4.i386.rpm
only to find out that the -c switch is broken in that release! The above 2
'patches' fix one problem but not the other... so as far as I'm concerned, this
is a catch-22 situation... is there a ping out there for RH 6.1 that actually
works the way it should? If there is, please give specific URL location(s) for
them... if there is a procedure or workaround, please state it in an unambiguous
manner. I have read all the mozilla bug reports regarding ping (quite a few) and
have read only generic statements from the developer(s) who are addressing this
problem.

Comment 7 Jeff Johnson 2000-02-27 17:52:59 UTC
The package iputils-991024-5 (which contains ping) from Raw Hide
	ftp://rawhide.redhat.com
fixes the problems described above as well as returning a valid exit code.

Comment 8 Pekka Savola 2000-07-18 22:09:34 UTC
*** Bug 13211 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.