Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86589 - Hardware Browser (hwbrowser) Crashes on Startup
Summary: Hardware Browser (hwbrowser) Crashes on Startup
Keywords:
Status: CLOSED DUPLICATE of bug 60133
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: hwbrowser
Version: 2.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-26 01:59 UTC by David Deaderick
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:18 UTC


Attachments (Terms of Use)

Description David Deaderick 2003-03-26 01:59:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020501

Description of problem:
Hardware Browser crashes on Startup with thefollowing output:

Traceback (innermost last):
  File "/usr/share/hwbrowser/DeviceList.py", line 158, in ?
    setup_ui ()
  File "/usr/share/hwbrowser/DeviceList.py", line 151, in setup_ui
    DeviceDisk.initialize (xml, hardware)
  File "/usr/share/hwbrowser/DeviceDisk.py", line 398, in initialize
    disk = parted.PedDevice.get ('/dev/' + device.kudzu_device.device)
TypeError: illegal argument type for built-in operation


Disk Partitions:

Disk /dev/sda: 255 heads, 63 sectors, 4462 cylinders
Units = cylinders of 16065 * 512 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/sda1   *         1         8     64228+  83  Linux
/dev/sda2             9       204   1574370   82  Linux swap
/dev/sda3           205       400   1574370   82  Linux swap
/dev/sda4           401      4462  32628015    5  Extended
/dev/sda5           401       661   2096451   83  Linux
/dev/sda6           662       726    522081   83  Linux
/dev/sda7           727       791    522081   83  Linux
/dev/sda8           792      1185   3164773+  83  Linux
/dev/sda9          1186      1218    265041   83  Linux
/dev/sda10         1219      4462  26057398+  83  Linux



lilo.conf:

prompt
timeout=50
default=linux
boot=/dev/sda
map=/boot/map
install=/boot/boot.b
message=/boot/message
linear

image=/boot/vmlinuz-2.4.9-e.5smp
	label=linux
	initrd=/boot/initrd-2.4.9-e.5smp.img
	read-only
	root=/dev/sda6
	append="hda=ide-scsi"

image=/boot/vmlinuz-2.4.9-e.5
	label=linux-up
	initrd=/boot/initrd-2.4.9-e.5.img
	read-only
	root=/dev/sda6


modules.conf:

alias parport_lowlevel parport_pc
alias eth0 eepro100
alias scsi_hostadapter aic7xxx 
alias usb-controller usb-ohci
options ide-cd ignore=hdc
pre-install sg modprobe ide-scsi



Version-Release number of selected component (if applicable):
hwbrowser-0.3.5-2

How reproducible:
Always

Steps to Reproduce:
1.Type hwbrowser on command line.
2.
3.
    

Actual Results:  Hardware browser crashes during device probe.

Expected Results:  Hardware Browser application should start, probe hardware and
display results

Additional info:

/var/log/messages:

Mar 25 20:49:00 VHAISPORAX1 kernel: 0x378: FIFO is 16 bytes
Mar 25 20:49:00 VHAISPORAX1 kernel: 0x378: writeIntrThreshold is 8
Mar 25 20:49:00 VHAISPORAX1 kernel: 0x378: readIntrThreshold is 8
Mar 25 20:49:00 VHAISPORAX1 kernel: parport0: PC-style at 0x378 (0x778)
[PCSPP,TRISTATE,COMPAT,EPP,ECP]
Mar 25 20:49:00 VHAISPORAX1 kernel: parport0: irq 7 detected
Mar 25 20:51:36 VHAISPORAX1 gconfd (root-1334): 2 items remain in the cache
after cleaning already-synced items older than 300 seconds

Comment 1 Brent Fox 2003-03-26 17:25:53 UTC

*** This bug has been marked as a duplicate of 60133 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:18 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.