Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86582 - glibc errata busted gdb
Summary: glibc errata busted gdb
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 8.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-25 22:10 UTC by Christopher Blizzard
Modified: 2016-11-24 15:07 UTC (History)
9 users (show)

Fixed In Version: 2.3.2-4.80.6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-10-03 10:48:48 UTC


Attachments (Terms of Use)

Description Christopher Blizzard 2003-03-25 22:10:19 UTC
Description of problem:

glibc errata busted gdb

Version-Release number of selected component (if applicable):

2.3.2-4.80

How reproducible:

Try to debug Mozilla.

Steps to Reproduce:
1. Try to start up Mozilla in gdb.
    
Actual results:

gdb will start spewing errors like:

Program received signal SIG32, Real-time event 32.

Expected results:

Program should be debugged as normal.

Additional info:

This happened when the glibc update was released.  Lots of people are reporting
this.  We need to unscrew it.

Comment 1 Jakub Jelinek 2003-03-27 18:08:52 UTC
Can you please try ftp://people.redhat.com/jakub/glibc/errata/8.0/ ?

Comment 2 Need Real Name 2003-03-27 18:21:29 UTC
In case anyone finds it useful, I filed a detailed report about this
bug as a gdb bug, number 1154.  You can see that here:

    http://sources.redhat.com/cgi-bin/gnatsweb.pl

I wasn't debugging mozilla, but a different large, multithreaded program.
Same results though: gdb doesn't work at all for my program.


Comment 3 Jakub Jelinek 2003-03-27 18:35:02 UTC
FYI in the errata there is no NPTL, just two copies of linuxthreads (floating
stacks and non-floating-stacks). Because of a bug in the kernel and bugfix
in glibc only non-floating-stacks linuxthreads are used in 2.3.2-4.80,
so in 2.3.2-4.80.1 I've backed out the glibc bugfix so that floating-stacks
libpthread can be used unless LD_ASSUME_KERNEL=2.2.5 or kernel too old.

Comment 4 Jonathan Biggar 2003-03-27 22:26:41 UTC
I tried the 2.3.2-4.80.1 packages from 
ftp://people.redhat.com/jakub/glibc/errata/8.0/

Didn't help.  Gdb still refuses to recognize threaded programs.

Comment 5 Jakub Jelinek 2003-03-29 08:57:15 UTC
Oops, sorry. Actually more work was needed to make /lib/i686 libs to be used
even when the kernel supplies broken AT_PLATFORM aux vector value.
Can you try: ftp://people.redhat.com/jakub/glibc/errata/8.0/*4.80.3* ?

Comment 6 Andrew Schultz 2003-03-30 04:23:08 UTC
I'm no longer seeing the SIG32 problems with *4.80.3 packages

Comment 7 Need Real Name 2003-04-02 18:40:31 UTC
*4.80.3 fixed my gdb problems as well.


Comment 8 Ulrich Drepper 2003-10-03 10:48:48 UTC
Should be fixed in the last errata.


Note You need to log in before you can comment on or make changes to this bug.