Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86552 - Updates for 7x depend on python >=2.2 should be python2
Summary: Updates for 7x depend on python >=2.2 should be python2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-25 13:03 UTC by Jon Burgess
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-28 19:41:31 UTC


Attachments (Terms of Use)

Description Jon Burgess 2003-03-25 13:03:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
When trying to update the rpm packages on RH7.3 using the rpm-4.0.5 packages
there is an error because the dependency on python is not satisfied

Version-Release number of selected component (if applicable):
rpm-python-4.0.5-0.1.7x

How reproducible:
Always

Steps to Reproduce:
1. Download updated packages from ftp://ftp.rpm.org/pub/rpm/test-4.0.5
2. rpm -Fvh <packages>

    

Actual Results: 
[root@vectra rpm]# rpm -Fvh *4.0.5*.7x.i386.rpm popt-1.6.5-0.1.7x.i386.rpm
error: failed dependencies:
        python >= 2.2 is needed by rpm-python-4.0.5-0.1.7x
        popt = 1.6.4 is needed by rpm-perl-4.0.4-7x.18
        rpm = 4.0.4 is needed by rpm-perl-4.0.4-7x.18


Expected Results: 
The rpm-python pacakge should probably depend on "python2>=2.2"
The rpm-perl packages is not supplied in the updates so I had to remove it -
perhaps it should be supplied or obsoleted?

[root@vectra rpm]# rpm -q python
python-1.5.2-43.73
[root@vectra rpm]# rpm -q python2
python2-2.2.2-11.7.3


Additional info:

Comment 1 Jeff Johnson 2003-03-28 19:41:31 UTC
Actually, rpm-4.0.5 needs python 1.5, not python2.

Fixed in rpm-4.0.5-1 errata, thanks for checking and reporting.


Note You need to log in before you can comment on or make changes to this bug.