Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86533 - keyboard stops responding in KDE eventually
Summary: keyboard stops responding in KDE eventually
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdelibs
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-25 08:30 UTC by Alexey Neyman
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-02 12:13:36 UTC


Attachments (Terms of Use)

Description Alexey Neyman 2003-03-25 08:30:26 UTC
Description of problem: 
Sometimes KDE stops receiving keyboard input. Mouse works ok, and so do 
the rest of applications. However, no keyboard input passes to the 
applications. I've observed this 3 times, each time in case of different 
activity (Konqueror, Konsole, MPlayer). 
 
Hitting ctrl-alt-backspace kills X server successfully, though. I also was 
able to log out from KDE session that brought me to the KDM login prompt; 
keyboard started responding again. 
 
Last time it happened I also noticed that the keyboard layout switcher's 
icon disappeared in the system tray when the keyboard hung. 
 
Version-Release number of selected component (if applicable): 
kdelibs-3.0.3-8 
Though I am not sure which component is in charge of this... 
 
How reproducible: 
Hardly; usually happens in 3-4 days of X session uptime.

Comment 1 Ngo Than 2003-03-26 13:52:06 UTC
Could you please tell me how i can produce this bug?

There is new kde 3.1.1 for 8.0 on ftp.kde.org. Could you please try kde-3.1.1
from ftp.kde.org. Does it fix this problem for you?



Comment 2 Alexey Neyman 2003-03-26 14:07:41 UTC
I cannot reproduce it reliably, it just happens from time to time. 
I'll try the recent KDE packages and see if it helps. 
 

Comment 3 Alexey Neyman 2003-04-02 12:13:36 UTC
Seems that upgrading to 3.1.1 solves this problem. A week has passed withough 
any evidence of such mishaps. 


Note You need to log in before you can comment on or make changes to this bug.