Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86516 - Illegal instruction when compiling php
Summary: Illegal instruction when compiling php
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-25 00:51 UTC by connie
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-11 09:43:48 UTC


Attachments (Terms of Use)
dmesg (deleted)
2003-03-25 00:56 UTC, connie
no flags Details
/var/log/ksyms.0 (deleted)
2003-03-25 00:57 UTC, connie
no flags Details

Description connie 2003-03-25 00:51:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Description of problem:
Compiling PHP 4 I get the following error
--------------------------------
[root@spike php-4.3.1]# make
gcc  -Iext/ctype/ -I/data/apps/php-4.3.1/ext/ctype/ -DPHP_ATOM_INC
-I/data/apps/php-4.3.1/include -I/data/apps/php-4.3.1/main
-I/data/apps/php-4.3.1 -I/data/apps/php-4.3.1/Zend
-I/data/apps/php-4.3.1/ext/xml/expat  -I/data/apps/php-4.3.1/TSRM  -g -O2  -c
/data/apps/php-4.3.1/ext/ctype/ctype.c -o ext/ctype/ctype.o  && echo >
ext/ctype/ctype.lo
/data/apps/php-4.3.1/ext/ctype/ctype.c: In function `zif_ctype_alnum':
/data/apps/php-4.3.1/ext/ctype/ctype.c:124: Internal error: Illegal instruction.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make: *** [ext/ctype/ctype.lo] Error 1


Load ave does appear to be broken and has been since install. Various /proc
entries are attached.





Version-Release number of selected component (if applicable):
gcc-2.96-113

How reproducible:
Always

Steps to Reproduce:
1. configure php with:
'./configure' \
'--with-mysql' \
'--enable-track-vars' \
'--with-apache=../apache_1.3.27' \
'--enable-ftp' \
'--with-pear' \
'--enable-force-cgi-redirect' \
"$@"

2. Run make
3.
    

Actual Results:  /data/apps/php-4.3.1/ext/ctype/ctype.c: In function
`zif_ctype_alnum':
/data/apps/php-4.3.1/ext/ctype/ctype.c:124: Internal error: Illegal instruction.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make: *** [ext/ctype/ctype.lo] Error 1


Additional info:

Comment 1 connie 2003-03-25 00:56:19 UTC
Created attachment 90704 [details]
dmesg

Comment 2 connie 2003-03-25 00:57:04 UTC
Created attachment 90705 [details]
/var/log/ksyms.0

Comment 3 connie 2003-04-11 09:43:48 UTC
Did a 6 hour memtest86, it is not the memory. Moving things in and out I managed
to locate the problem. The High point onboard RAID Controller. When I switched
the system to software RAID all is working fine.

Aviod High Point onbard RAID like the Plague.


Note You need to log in before you can comment on or make changes to this bug.