Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86511 - virtual terminals 7-12 display cyrillic chars vice color/bold
Summary: virtual terminals 7-12 display cyrillic chars vice color/bold
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: groff
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-24 22:33 UTC by Need Real Name
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-06-14 16:02:26 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-03-24 22:33:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.2) Gecko/20030208
Netscape/7.02

Description of problem:
Virtual terminals 7-11 enabled via inittab (or openvt -c11 bash).  Data
displayed on these terminals that is intended to be in color or bold is
displayed in the proper color (or bold), but with cyrillic characters. (e.g.
output of ls, vi, or man)

man foo | col -b gives correct characters, but no bold
ls --color=never gives correct characters, but no color

stty -a produces same data for all virtual terminals

LC_ALL can be defined to en_US.UTF-8  with no effect

Problem does not exist with RedHat 7.3 (/etc/termcap is same on both systems)

Some unknown action can remove problem temporarily.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Login to vt 7 -> 11  (or openvt -c10 bsah..)
2. vi anyfile    or ls  (--color=auto)  with files that are exec or directories
3. or...man man
    

Actual Results:  any text that is intended to be bold or in color is so, but the
characters are cyrillic

Expected Results:  expected Latin

Additional info:

Comment 1 Miloslav Trmac 2003-03-25 13:21:25 UTC
This is in /etc/rc.d/rc.sysinit, you might want to try adding numbers
to the "2 3 4 5 6" below.

 # Load system font
 if [ -x /sbin/setsysfont ]; then
    [ -f /etc/sysconfig/i18n ] && . /etc/sysconfig/i18n
    for i in 2 3 4 5 6; do
      > /dev/tty$i
    done
    case "$LANG" in
      *.utf8*|*.UTF-8*)
        action $"Setting default font ($SYSFONT): " /bin/unicode_start $SYSFONT
        ;;
      *)
        action $"Setting default font ($SYSFONT): " /sbin/setsysfont
        ;;
    esac
 fi



Note You need to log in before you can comment on or make changes to this bug.