Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86510 - some driver options (Double-Sided Printing) not saved
Summary: some driver options (Double-Sided Printing) not saved
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: foomatic
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
: 90864 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-24 22:32 UTC by Chris MacGregor
Modified: 2007-04-18 16:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-26 17:56:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:185 normal SHIPPED_LIVE Updated printer database available 2003-06-09 04:00:00 UTC

Description Chris MacGregor 2003-03-24 22:32:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
With a printer configured to use the HP LaserJet 8150 Postscript driver, 
changes made to the "Double-Sided Printing" option on the Driver Options tab
don't get saved.  Specifically, it insists on being set to "On".  The Paper Size
option works normally.  I haven't experimented with the other options, or with
other printer types.

May or may not be related:
I was very surprised to see that the Page Size option apparently defaulted to
A4.  If I wasn't in the US, I'd probably be less surprised...

Version-Release number of selected component (if applicable):
redhat-config-printer-gui-0.4.24-1

How reproducible:
Always

Steps to Reproduce:
1. Add a printer, as an HP LaserJet 8150, Postscript.
2. Select that printer and click Edit.
3. Click the Driver Options tab.
4. Change Double-Sided Printing from On to Off.
5. Click OK.
6. Click Edit again.
7. Click the Driver Options tab again.
8. Observe that Double-Sided Printing is set to On.
9. Repeat until convinced that it's not pilot error.
    

Actual Results:  In step 8 I observed that Double-Sided Printing was set to On.

Expected Results:  It should have been set to Off.

Additional info:

Comment 1 Tim Waugh 2003-03-25 13:52:31 UTC
Reported upstream as:
http://www.linuxprinting.org/pipermail/foomatic-devel/2003q1/001438.html

Comment 2 Tim Waugh 2003-03-26 17:56:27 UTC
Fixed package is foomatic-2.0.2-18.

Comment 3 Tim Waugh 2003-05-14 22:04:57 UTC
*** Bug 90864 has been marked as a duplicate of this bug. ***

Comment 4 Tim Waugh 2003-06-09 09:56:55 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-185.html


Comment 5 Burt Holzman 2003-10-20 14:01:30 UTC
Just a note -- this errata should also be included in the Red Hat 8.0 updates,
not just Red Hat 9.

- B


Note You need to log in before you can comment on or make changes to this bug.