Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86486 - RPM database corruption in failed (single) package update
Summary: RPM database corruption in failed (single) package update
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-24 03:49 UTC by keithu@parl.clemson.edu
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-28 19:45:35 UTC


Attachments (Terms of Use)

Description keithu@parl.clemson.edu 2003-03-24 03:49:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
I ran an rpm -i for kernel-2.4.18-27.7.x and it hung (for a LONG time).  I did
Ctrl-C and tried again.  Same result.  Now, I have two entries for it in the RPM
database (and so can't remove it - rpm complains that the name specifies
multiple packages).  Now what?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.fail an RPM install
2.try again
3.try to remove the RPM 
    

Additional info:

Comment 1 Jeff Johnson 2003-03-28 19:45:35 UTC
Do
   rpm -evv --allmatches kernel-X-Y
where X == the version, and Y == the release, you want to remove.

If still hanging, do
    rm -f /var/lib/rpm/__db*
first.

Comment 2 keithu@parl.clemson.edu 2003-03-28 20:22:10 UTC
Thanks.  Worked great.  BTW, do you just put the vv in there as vengence against
those who fail to RTFM? ;-)


Note You need to log in before you can comment on or make changes to this bug.