Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86482 - Internal compiler error when rpmbuild --rebuild glibc
Summary: Internal compiler error when rpmbuild --rebuild glibc
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc
Version: 8.0
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-24 00:40 UTC by Ken MacFarlane
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-03 13:00:14 UTC


Attachments (Terms of Use)

Description Ken MacFarlane 2003-03-24 00:40:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2.1) Gecko/20030315

Description of problem:
Receive following when doing rpmbuild --rebuild --target=i586
glibc-2.3.2-4.80.src.rpm:

make[2]: Entering directory `/usr/src/redhat/BUILD/glibc-2.3.2-20030312/elf'
dynamic-link.h:167: Internal compiler error in output_die, at dwarf2out.c:6425
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: ***
[/usr/src/redhat/BUILD/glibc-2.3.2-20030312/build-i586-linux/elf/dl-conflict.o]
Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/glibc-2.3.2-20030312/elf'



Version-Release number of selected component (if applicable):
glibc-2.3.2-4.80

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild --target=i586 glibc-2.3.2-4.80.src.rpm

    

Actual Results:  see description

Additional info:

built with gcc-3.2.2-1, glic-2.2.93-5, rpm-build-4.1-1.06

Comment 1 Ulrich Drepper 2003-04-22 08:19:03 UTC
That's a compiler error.

Comment 2 Richard Henderson 2004-10-03 13:00:14 UTC
Glibc has certainly built since then.


Note You need to log in before you can comment on or make changes to this bug.