Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86477 - no valid PGP signature
Summary: no valid PGP signature
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-23 17:30 UTC by Kurt Scholtens
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-30 21:38:18 UTC


Attachments (Terms of Use)

Description Kurt Scholtens 2003-03-23 17:30:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When running up2date and downloading the latest kernel update, I run into the
following error message:
"The Package kernel-2.4.18-27.8.0 does not have a valid GPG signature.  It has
been tampered with or corrupted. Continue?"

Here is the output of rpm -q gpg-pubkey:

gpg-pubkey-db42a60e-37ea5438

Like the previous user having problems with this issue, I am also connecting via
a 56k line.

Version-Release number of selected component (if applicable):
kernel-2.4.18-26.8.0

How reproducible:
Always

Steps to Reproduce:
1.Launch up2date
2.Select the kernel to be updated
3.Begin download - usually occurs after 12 - 20% of the download is complete.
    

Actual Results:  As described above, the error message seen above happens after
12 - 20% of the download is complete.

Expected Results:  An updated kernel.

Additional info:

Comment 1 R. Bruce 2003-05-10 05:37:35 UTC
There seems to be more than one Bugzilla filed with regarding RHN's recently
acquired inability to download large files of, say, >2 MB.  Allow me to add my
confirmation of an evidently ongoing problem I'm having whenever I try to
download large files from RHN.

Running Red Hat Linux 8: I consistently began to experience download problems
with larger files about 2-3 weeks ago.  This problem is relatively new: prior to
the degradation in service I successfully downloaded several hundred megabytes
worth of downloads via RHN over a period of 12 hours that included both daytime
and nighttime hours of operation.

Like other submitters of this particular type of bug, download of large files
via RHN "hang," followed by the message that the file's signature is invalid or
has been corrupted.

I am now unable to use RHN to reliably download larger files of, say, >= 2 MB. 
Smaller files have not yet been a problem.  What I have observed, subjectively,
is that downloadubg large files late at night seems to work better.  It seems to
me that subscriber demand is somehow breaking RHN during large-file downloads...(?)

Note that I am immediately able to use the very same dial-up connection that
fails with RHN to download 30+ MB files from other sites such as SUN.  I tested
this as a way of eliminating my dial-up connection and my R'Hat Linux 8
installation as culprits.

Cheers & hope this helps,
R. Bruce



Note You need to log in before you can comment on or make changes to this bug.