Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86474 - Dates in apache error pages are shown in wrong encoding
Summary: Dates in apache error pages are shown in wrong encoding
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: httpd
Version: 8.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-23 14:52 UTC by Christian Rose
Modified: 2007-03-27 04:01 UTC (History)
1 user (show)

Fixed In Version: 2.0.45-4
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-18 19:02:06 UTC


Attachments (Terms of Use)
Screenshot that shows the wrong encoding (deleted)
2003-03-23 14:53 UTC, Christian Rose
no flags Details

Description Christian Rose 2003-03-23 14:52:22 UTC
Tested on a RHL 8.0 system with sv_SE.UTF-8 locale.

The dates in the default apache error pages seem to be encoded wrongly. They
seem to be encoded in UTF-8 although the page source specifies that the page is
in iso-8859-1. Hence, web browsers will show the date improperly. I'm attaching
a screenshot that shows the problem.

Comment 1 Christian Rose 2003-03-23 14:53:22 UTC
Created attachment 90700 [details]
Screenshot that shows the wrong encoding

Comment 2 Joe Orton 2003-04-04 09:08:22 UTC
If you put LANG=C in /etc/sysconfig/httpd and restart httpd, does that fix the
problem? (or just LC_TIME=C)

Comment 3 Christian Rose 2003-04-06 21:31:07 UTC
LANG=C just gives the date in English (which is not what is wanted as the rest
of the error page is shown in proper Swedish) and LC_TIME=C just gives the same
as before (garbled Swedish).

Comment 4 Joe Orton 2003-04-06 22:33:43 UTC
Hmmm, yes; a more general statement of the problem is that the date formatting
for the error pages is done in the locale of the server thread, rather than the
content-language of the error page.  This is non-trivial to fix, to say the least.

I think the best thing to do in the medium term is to simply remove the date
from the error pages.  Thanks for the report.

Comment 5 Joe Orton 2003-05-18 19:02:06 UTC
The dates have now been removed from the error pages.


Note You need to log in before you can comment on or make changes to this bug.