Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86454 - rpm Hangs When Installing some packages via Nautilus
Summary: rpm Hangs When Installing some packages via Nautilus
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages
Version: 8.0
Hardware: athlon
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-22 11:39 UTC by Steven Bird
Modified: 2015-01-08 00:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-02 06:05:14 UTC


Attachments (Terms of Use)

Description Steven Bird 2003-03-22 11:39:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
All further rpm commands will hang after attempting to install an rpm package
via Nautilus when there is a newer rpm for the package already present on the
system. All rpm commands run afterwards simply hang, both at the command line or
via Nautilus. After trying various work arounds mainly logging out in various
ways, killing processes, etc), foudn that rpm will function properly after a
reboot and Nautilus does not try to install the offending rpm again. :(    

Version-Release number of selected component (if applicable):
nautilus-2.0.6-6

How reproducible:
Always

Steps to Reproduce:
1.Login as a non-root user into the default Gnome 2/Bluecurve desktop.
2.Find two different versions of the same RPM package (e.g gnomeicu)
3.Open Nautilus by clicking on the home icon on the desktop.
4. Install the later of the two packages by clicking on the icon in Nautilus and
entering the root password.
5. "Accidentally" attempt to install the earlier package by clicking on it as well.
6. After the dialog appears, warning that it will not install an earlier version
of a package already present, attempt to uninstall the  first package at the
console or a terminal with 'rpm -e <package>'. Infact. just try an 'rpm -qa' or
'rpm -q <package name>' They all produce the same result.
    

Actual Results:  All rpm commands will hang indefinitly, at a terminal or a
virtual console. No warnings or messages are given.

Expected Results:  rpm -e <package name> should erase the package, if it exists.
rpm -qa should produce a list of all packages found on the system, etc.

Additional info:

Yes, it's a minor bug. Yes, a workaround is simply not to use Nautilus to
install RPMs. However, this is an attempt to help refine areas of the desktop
experience. I am miagrating desktop users from Windows to Redhat Linux, and many
do prefer to simply use the desktop functionality whenever possible, including
installing new programs.

Comment 1 Alexander Larsson 2003-03-24 14:22:56 UTC
I'm reassigning this to redhat-config-packages, although it looks like a dup of
the "rpm hangs and leaves  /var/lib/rpm/__db.00* locks around.

Comment 2 Jeremy Katz 2003-04-02 06:05:14 UTC
Yeah, dupe of the rpm bug (that I don't remember off hand).  Not much
redhat-config-packages can do to work around it, but current versions of rpm are
better about this.


Note You need to log in before you can comment on or make changes to this bug.