Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86444 - rpm unpack error
Summary: rpm unpack error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-22 01:29 UTC by Paul La Marre
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-20 20:21:54 UTC


Attachments (Terms of Use)

Description Paul La Marre 2003-03-22 01:29:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461; Q312461)

Description of problem:
Red Hat Network, Update agent fails to install php-manual-4.2.2-8.0.7.

Error: rpm unpack error installing the package php-manual-4.2.2-8.0.7

Tried a number of times with other packages and along.

Version-Release number of selected component (if applicable):
php-manual-4.2.2-8.0.7

How reproducible:
Always

Steps to Reproduce:
1.run Red Hat Network (Update Agent) for php-manual...
2.
3.
    

Actual Results:  rpm unpack error

Expected Results:  installed package

Additional info:

Comment 1 Joe Orton 2003-04-07 12:10:56 UTC
Did you run out of disk space or something?  Please post a complete transcript
of this failing.

Comment 2 Paul La Marre 2003-04-07 18:15:07 UTC
No additional information unless you can point me to a log.

Up2date simply gives an error that it can not expand the
rpm.  Very general error message.  Drive space is not an
issue -- most other rpm's are ok.

I will be attempting to update to 9 as soon as the bandwidth
on your side allows.

Comment 3 Joe Orton 2003-04-07 18:33:53 UTC
I've seen some problems where doing:

  # rm -f /var/spool/up2date/*

has fixed problems, where a corrupt package has somehow been cached.  Can you
try that? 

Comment 4 Paul La Marre 2003-04-13 18:13:56 UTC
After "rm -f /var/spool/up2date/*" and download of rpm, I ran rpm and it 
installed.

Looks like the issue has to do with the content of the spooling area.
Exactly what ??  


Thanks.




Comment 5 Joe Orton 2003-04-13 19:32:51 UTC
I don't know, but up2date should handle this I guess.


Note You need to log in before you can comment on or make changes to this bug.