Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86440 - Realplayer not working with Red Hat Linux 8.0.94?
Summary: Realplayer not working with Red Hat Linux 8.0.94?
Keywords:
Status: CLOSED DUPLICATE of bug 87898
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-21 23:35 UTC by Kai 'wusel' Siering
Modified: 2016-11-24 14:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:16 UTC


Attachments (Terms of Use)

Description Kai 'wusel' Siering 2003-03-21 23:35:59 UTC
Description of problem:

realplayer dies with segfault.

Version-Release number of selected component (if applicable):

rp8_linux20_libc6_i386_cs2_rpm (from realnetworks.com)

How reproducible:

Install said rpm on 8.0.94, run (as normal user) "realplay", enter
your user data. After "finish" on any subsequent start, "realplay"
segfaults.

Steps to Reproduce:
1. Download & install rp8_linux20_libc6_i386_cs2_rpm
2. Start "realplay", enter registration data.
3. Back in the shell, start "realplay". Praise the segfault.
    
Actual results:

Won't work.

Expected results:

Should work.

Additional info:

strace of "realplay" (first run):

[...]
mmap2(NULL, 8388608, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_PRIVATE|MAP_ANONYMOUS,
-1, 0) = 0x40b3c000
mprotect(0x40b3c000, 4096, PROT_NONE)   = 0
clone(child_stack=0x4133b930,
flags=CLONE_VM|CLONE_FS|CLONE_FILES|CLONE_SIGHAND|CLONE_THREAD|CLONE_SETTLS|CLONE_PARENT_SETTID|CLONE_CHILD_CLEARTID|CLONE_DETACHED,
[26003], {entry_number:6, base_addr:0x4133bd40, limit:1048575, seg_32bit:1,
contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0, useable:1}) =
26003
nanosleep({0, 1000}, NULL)              = 0
futex(0x83dbcc8, FUTEX_WAKE, 1, NULL)   = 1
brk(0)                                  = 0x8407000
brk(0x840f000)                          = 0x840f000
futex(0x83dbcc8, FUTEX_WAKE, 2, NULL)   = 0
futex(0x83dbcc8, FUTEX_WAKE, 3, NULL)   = 0
open("/home/wusel/.RealNetworks_RealPlayer_60", O_WRONLY|O_CREAT|O_TRUNC, 0666)
= 7
flock(7, LOCK_EX)                       = 0
fstat64(7, {st_mode=S_IFREG|0664, st_size=0, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x40026000
flock(7, LOCK_UN)                       = 0
write(7, "ClientLicenseKey=000000000000700"..., 418) = 418
close(7)                                = 0
munmap(0x40026000, 4096)                = 0
open("/home/wusel/.RealNetworks_RealPlayer_60", O_RDONLY) = 7
flock(7, LOCK_EX)                       = 0
stat64("/home/wusel/.RealNetworks_RealPlayer_60", {st_mode=S_IFREG|0664,
st_size=418, ...}) = 0
futex(0x83d9f28, FUTEX_WAIT, -439, NULL) = -1 EINTR (Interrupted system call)
+++ killed by SIGSEGV +++

Comment 1 Jonathan Schatz 2003-04-07 22:03:25 UTC
i can confirm this on rh9.0. 

additionally, RealPlayer9 exhibits this same behavior:

[jon@jonschatz-lx RealPlayer9]$ ./realplay
http://www.dancerecords.com/topsellers.php?SID=\&week=1734\&genre=1
Segmentation fault (core dumped)
[jon@jonschatz-lx RealPlayer9]$ !gd
gdb ./realplay core.4029
warning: core file may not match specified executable file.
Core was generated by `./realplay
http://www.dancerecords.com/topsellers.php?SID=&week=1734&genre=1'.
Program terminated with signal 11, Segmentation fault.
#0  0x40433ddb in ?? ()
(gdb) bt
#0  0x40433ddb in ?? ()
#1  0x40432e21 in ?? ()
#2  0x402d4e01 in ?? ()
#3  0x4056f20b in ?? ()
#4  0x4056e622 in ?? ()
#5  0x4057265a in ?? ()
#6  0x40571f19 in ?? ()
#7  0x40287931 in ?? ()
#8  0x4028825d in ?? ()
#9  0x4028857f in ?? ()
#10 0x4057149c in ?? ()
#11 0x40570b29 in ?? ()
#12 0x40570aa3 in ?? ()
#13 0x4058de1c in ?? ()
#14 0x40ed3c45 in ?? ()
#15 0x40ed3143 in ?? ()
#16 0x409a5027 in ?? ()
#17 0x409a4847 in ?? ()
#18 0x4099a77b in ?? ()
#19 0x4099d90d in ?? ()
#20 0x4099c895 in ?? ()
#21 0x40a303eb in ?? ()
#22 0x40a26c94 in ?? ()
#23 0x40a379f3 in ?? ()
#24 0x40a38280 in ?? ()
#25 0x40a2ffb3 in ?? ()
#26 0x40ab71e0 in ?? ()
#27 0x40aa899c in ?? ()
#28 0x4058e321 in ?? ()
#29 0x40570b50 in ?? ()
#30 0x40570aa3 in ?? ()
#31 0x4062b6cd in ?? ()
#32 0x405f586e in ?? ()
#33 0x0804c8e2 in ?? ()
#34 0x0804b165 in ?? ()
#35 0x403d5917 in ?? ()

Comment 2 Jonathan Schatz 2003-04-07 22:54:17 UTC
ok, i managed to get both versions working by upgrading my codecs here:

http://realforum.real.com/cgi-bin/unixplayer/showthreaded.pl?Cat=&Board=announcements&Number=3128&page=0&view=collapsed&sb=5



Comment 3 Mike A. Harris 2003-04-19 09:00:09 UTC

*** This bug has been marked as a duplicate of 87898 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:52:16 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.