Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 864363 - ovirt-engine-webadmin-portal: New VM Pool button should be grayed out when there are no templates (except Blank template)
Summary: ovirt-engine-webadmin-portal: New VM Pool button should be grayed out when th...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Kobi
QA Contact: Ilanit Stein
URL:
Whiteboard: virt
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2012-10-09 08:54 UTC by Oded Ramraz
Modified: 2014-09-21 16:36 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.4.0-alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 21579 None None None Never

Description Oded Ramraz 2012-10-09 08:54:31 UTC
Description of problem:

New VM Pool button should grayed out when there are no templates since no templates can be created anyway . IMO It will reduce possible confusion .

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Oded Ramraz 2012-10-09 08:57:45 UTC
(In reply to comment #0)
> Description of problem:
> 
> New VM Pool button should grayed out when there are no templates since no
> templates can be created anyway . IMO It will reduce possible confusion .
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1.
> 2.
> 3.
>   
> Actual results:
> 
> 
> Expected results:
> 
> 
> Additional info:

I meant no VM pools can be created .

Comment 4 Sandro Bonazzola 2014-01-14 08:44:05 UTC
ovirt 3.4.0 alpha has been released

Comment 5 Ilanit Stein 2014-02-02 22:24:55 UTC
Can the "New" button be grayed out in case there is no templates?

Comment 6 Kobi 2014-02-10 09:39:42 UTC
For consistency reasons, the "New" button will not be grayed out, we are disabling the whole window after opening it and showing a warning message in the bottom. like in no DCs are available case.

Comment 7 Ilanit Stein 2014-03-18 14:34:35 UTC
Verified on av3.

Comment 8 Itamar Heim 2014-06-12 14:10:08 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.