Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86427 - local mail bounces after sendmail 8.12.8 update
Summary: local mail bounces after sendmail 8.12.8 update
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-21 20:21 UTC by Al Sera
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-05 10:35:22 UTC


Attachments (Terms of Use)

Description Al Sera 2003-03-21 20:21:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030208
Netscape/7.02

Description of problem:
After installing the sendmail 8.12.8 update, local mail on the system is
bouncing. The bounced message indicates

(reason: 553 5.5.4 <root@localhost.localdomain>... Real domain name
required for sender address)
    (expanded from: root)

Sample instance of a bounced mail from /var/log/maillog in "Additional
Information" section.

This system has always run with sendmail without customizations. Users use
Netscape for email. Local mail is used by Logwatch.

Version-Release number of selected component (if applicable):
sendmail-8.12.8-1.80

How reproducible:
Always

Steps to Reproduce:
1.Run mail, or pine(using for test)
2.To: root (from root), Subj: Test, Body: Test
3.Send mail and exit pine
4.Re-enter pine
    

Actual Results:  Bounced mail present in inbox with reason error code & message
as decribed before.

Expected Results:  Mail should have been delivered and not bounced back.

Additional info:
/var/log/maillog event sample:
Mar 21 13:50:54 mthood sendmail[11383]: h2LIosB6011383:
from=<root@localhost.localdomain>, size=281, class=0, nrcpts=1,
msgid=<Pine.LNX.4.44.0303211350410.11382-100000@localhost.localdomain>,
proto=ESMTP, relay=root@localhost
Mar 21 13:50:54 mthood sendmail[11387]: h2LIosPe011387: ruleset=check_mail,
arg1=<root@localhost.localdomain>, relay=localhost [127.0.0.1] (may be forged),
reject=553 5.5.4 <root@localhost.localdomain>... Real domain name required for
sender address
Mar 21 13:50:54 mthood sendmail[11386]: h2LIosB6011383:
to=<root@localhost.localdomain>, ctladdr=<root@localhost.localdomain> (0/0),
delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30275, relay=[127.0.0.1]
[127.0.0.1], dsn=5.6.0, stat=Data format error
Mar 21 13:50:54 mthood sendmail[11386]: h2LIosB6011383: h2LIosB5011386: DSN:
Data format error
Mar 21 13:50:54 mthood sendmail[11387]: h2LIosPe011387:
from=<root@localhost.localdomain>, size=281, class=0, nrcpts=0, proto=ESMTP,
daemon=MTA, relay=localhost [127.0.0.1] (may be forged)
Mar 21 13:50:54 mthood sendmail[11387]: h2LIosPf011387: from=<>, size=2314,
class=0, nrcpts=1, msgid=<200303211850.h2LIosB5011386@localhost.localdomain>,
proto=ESMTP, daemon=MTA, relay=localhost [127.0.0.1] (may be forged)
Mar 21 13:50:54 mthood sendmail[11386]: h2LIosB5011386:
to=<root@localhost.localdomain>, delay=00:00:00, xdelay=00:00:00, mailer=relay,
pri=31305, relay=[127.0.0.1], dsn=2.0.0, stat=Sent (h2LIosPf011387 Message
accepted for delivery)
Mar 21 13:50:54 mthood sendmail[11388]: h2LIosPf011387:
to=<root@localhost.localdomain>, delay=00:00:00, xdelay=00:00:00, mailer=local,
pri=32536, dsn=2.0.0, stat=Sent

Comment 1 Florian La Roche 2003-05-05 10:35:22 UTC
You might want to fix /etc/hosts for this to work again. Seems to be a local
configuration problem on your machine.

greetings,

Florian La Roche


Comment 2 Al Sera 2003-05-05 12:28:18 UTC
There was no probelm with /etc/hosts. After extensive research at the
sendmail.org web site, the only work around for the problem I could devise was
to add
FEATURE(`accept_unqualified_senders')dnl to sendmail.mc and then recompiling.
This is not a clean solution but will do for the time being since I do not
accept external LAN mail since sendmail is not fully configured. I have upgraded
to RH Linux 9 with this same sendmail configuration. Final goal will be to
configure sendmail to accept internal LAN mail only to keep security related
data internally.


Note You need to log in before you can comment on or make changes to this bug.