Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86417 - Update causes lots of errors in .xsession-errors from rhn-applet-gui
Summary: Update causes lots of errors in .xsession-errors from rhn-applet-gui
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-21 18:00 UTC by Jon Burgess
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-21 18:04:34 UTC


Attachments (Terms of Use)

Description Jon Burgess 2003-03-21 18:00:40 UTC
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux) 
 
Description of problem: 
I updated to rpm-4.1.1-0.2.8x and now my ~/.xession-erros is filling up with errors like: 
 
rpmdb: /var/lib/rpm/Packages: unsupported hash version: 8 
rpmdb: /var/lib/rpm/Packages: unsupported hash version: 8 
rpmdb: /var/lib/rpm/Packages: unsupported hash version: 8 
ain't there yet 
ain't there yet 
ain't there yet 
 
I then removed the applet from my taskbar and the message have stopped 
 
I think this is caused by the upgrade of rpm, although the bug could in fact be somewhere 
else, but I trust Jeff will know which direction to push this. 
 
My guess is that python is using librpmdb404 and it doesn't like the new rpm db's created by 
rpm-4.1.1 
 
Version-Release number of selected component (if applicable): 
Basically RH8 + RPM updates 
rpm-4.1.1-0.2.8x  
rpm-build-4.1.1-0.2.8x 
rpm404-python-4.0.4-8x.27 
rpm-devel-4.1.1-0.2.8x 
rpm-python-4.1.1-0.2.8x 
librpm404-4.0.4-8x.27 
rhnlib-1.0-1 
rhn-applet-2.0.0-28 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Update rpm to specified version & then login to X 
2. Examine the contents of ~/.xsession-errors 
3. 
     
 
Expected Results:  No error messages 
 
Additional info:

Comment 1 Jeff Johnson 2003-03-21 18:04:34 UTC
Run
    /usr/lib/rpm/rpmdb_loadcvt
to change to db-4.0.14 compatible format.


Comment 2 Jon Burgess 2003-03-21 18:36:13 UTC
Thanks, that fixed it.


Note You need to log in before you can comment on or make changes to this bug.