Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86391 - [RFE] Specify VNC Server Parameters
Summary: [RFE] Specify VNC Server Parameters
Keywords:
Status: CLOSED DUPLICATE of bug 60176
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vnc
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-21 06:19 UTC by James Barwick
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:15 UTC


Attachments (Terms of Use)

Description James Barwick 2003-03-21 06:19:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Description of problem:
To keep everyone from having to MODIFY startup scripts every time we
install RH...PLEASE...oh PLEASE make this VERY SIMPLE change....
 
/etc/rc.d/init.d/vncservers
 
Change the startup line to:
"su ${display##*:} -c \"cd ~${display##*:} && [ -f .vnc/passwd ] &&
vncserver $VNCOPTIONS :${display%%:*}\""
 
We can then put VNCOPTIONS in /etc/sysconfig/vncservers
 
PLEASE!!!!!  This is WAY SIMPLE.  There should be NO REASON for you not to
comply with this request.	This will take all of 2-1/2 seconds for someone to add
to the distribution RPM.  

This just makes the product BETTER.  Come on...this is too too simple.  Yes I
can do it EVERY time I install.  But, you would look much better if I didn't.
 
You should really honor these NON-IMPACT modification requests by your
customers.  Only makes you look better.
 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure /etc/sysconfig/vncserver
2. run "service vncserver start"
3. no way "out of the box" to specify vncserver parameters
    

Actual Results:  Be able to start the server with a specified screen size and
color depth

Expected Results:  unable to start the server with a specified screen size and
color depth without modifying the /etc/rc.d/vncserver script

Additional info:

Comment 1 Tim Waugh 2003-03-21 14:55:25 UTC

*** This bug has been marked as a duplicate of 60176 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.