Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86384 - RAID corruption after 7.3->8.0 installation
Summary: RAID corruption after 7.3->8.0 installation
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: raidtools
Version: 8.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Doug Ledford
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-21 00:28 UTC by Stephen Walton
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-11-27 23:24:59 UTC


Attachments (Terms of Use)

Description Stephen Walton 2003-03-21 00:28:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I have two systems, one brand new dual Athlon and one ancient 150 MHz Pentium,
on which I've installed RH 8.0 on a SCSI disk replacing RH 7.3.  Both systems
had file systems on a pair of IDE disks formatted as RAID-0.

After the RH 8.0 installations and re-creation of /etc/raidtab, both systems
RAID arrays startet throwing very similar errors of the form:

hdc: read_intr: status=0x59 { DriveReady SeekComplete DataRequest Error }
hdc: read_intr: error=0x10 { SectorIdNotFound }, LBAsec=200, sector=154

as well as

EXT3-fs error (device md(9,0)): ext3_get_inode_loc: unable to read inode block

and similarly scary messages.  Now, I at first thought the problem was due to an
IDE disk failure on the dual Athlon system, and indeed a diagnostic showed
problems with one of the two IDE disks.  However, just now the P150 which was
updated two days ago started throwing similar errors.  It seems highly unlikely
that both systems had IDE disks which failed in the same way right after an RH
8.0 update.


Version-Release number of selected component (if applicable):
raidtools-1.00.2-3.3

How reproducible:
Always

Steps to Reproduce:
1.  Create a two-disk data RAID0 under RedHat 7.3.
2.  Install RH 8.0 on that system.
3.
    

Actual Results:  Errors and data corruption.

Expected Results:  The contents of the old data disk should have worked fine
under RH 8.0.

Additional info:


Note You need to log in before you can comment on or make changes to this bug.