Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86377 - G400 DRI bad texturing in 4.2.99 and 4.3
Summary: G400 DRI bad texturing in 4.2.99 and 4.3
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86
Version: 1.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-20 21:34 UTC by Luca Barbieri
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-17 10:32:01 UTC


Attachments (Terms of Use)

Description Luca Barbieri 2003-03-20 21:34:45 UTC
Description of problem:
Quake2 on a machine with a G400 card and XFree 4.3 has horrible graphics due to
incorrectly colored polygons.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2.1
Also present in latest 4.2.99 and 2002-11-26 XFree86 4.2.99
linux-2.5.65-mm2 (also seen with older 2.5 kernels)

How reproducible:
Always

Steps to Reproduce:
1. Start Quake2 on any map
2. Shoot by keeping the left mouse button pressed
    
Actual results:
Floor polygons light up in red, green and blue.

Expected results:
A yellow light should move across the floor on each shot.

Workaround:
Overwriting mga_dri.so with the version from RHL 8.0 XFree 4.2 fixes the problem
and doesn't seem to have adverse effects.

Comment 1 Mike A. Harris 2003-03-21 16:14:41 UTC
Please report these types of problems upstream to the Mesa and/or DRI
projects to investigate and resolve.  When the problem is fixed upstream,
it may possibly be incorporated into the next version of Red Hat Linux,
either by updating to a new XFree86 release containing the fix, or by
backported fixes.

Comment 2 Mike A. Harris 2003-03-21 16:18:43 UTC
>linux-2.5.65-mm2 (also seen with older 2.5 kernels)

Not to mention the fact you're using a non-Red Hat kernel.


Comment 3 Mike A. Harris 2003-07-17 10:31:48 UTC
I'm processing UPSTREAM flagged bug reports for upstream fixes currently, and
noticed that this bug was flagged upstream but has no upstream bug URL, and I
was unable to find an upstream bug report of this issue in XFree86 bugzilla
located at:

    http://bugs.xfree86.org

Closing bug report as WONTFIX as I'm unable to track upstream until a bug
report has been filed upstream, and the URL provided for tracking.  If this
issue is still relevant in the latest XFree86 packages in rawhide, after
reporting upstream at http://bugs.xfree86.org, feel free to add the bug
report URL to this report and reopen if you'd like the issue to be tracked
and any fixes from upstream investigated for inclusion in future Red Hat
XFree86 updates.




Note You need to log in before you can comment on or make changes to this bug.