Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 863757 - [RFE] [rhevm-dwh] - Cleanup Tool - Removing/Cleaning DWH installation
Summary: [RFE] [rhevm-dwh] - Cleanup Tool - Removing/Cleaning DWH installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.1.0
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: ---
: 3.4.0
Assignee: Sandro Bonazzola
QA Contact: Barak Dagan
URL:
Whiteboard: integration
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2012-10-07 09:12 UTC by David Botzer
Modified: 2014-09-18 12:24 UTC (History)
10 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Enhancement
Doc Text:
A cleanup tool for removing/cleaning Data Warehouse installation is now available with the inclusion of OTOPI. Cleanup is available by running the 'engine-cleanup' command.
Clone Of:
Environment:
Last Closed: 2014-06-09 15:16:05 UTC
oVirt Team: ---
Target Upstream Version:
dyasny: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0601 normal SHIPPED_LIVE rhevm-dwh 3.4 bug fix and enhancement update 2014-06-09 19:15:53 UTC

Description David Botzer 2012-10-07 09:12:07 UTC
Description of problem:
RFE Cleanup Tool - For Removing/Cleaning DWH installation

Version-Release number of selected component (if applicable):
3.1/si20

How reproducible:
Always

Steps to Reproduce:
1.Install rhevm+dwh+reports
2.Remove installation of (1)

  
Actual results:
User cannot be sure all DWH components were removed

Expected results:
Should remove all relevant DWH components

Additional info:

Comment 1 Dan Yasny 2013-02-07 11:35:12 UTC
Requirements:

1. be able to remove only the reports/dwh leaving rhevm intact
2. be able to clean up the history db, so that it's clean, but reports remain operational and ETL start gathering data from this moment on
3. rhevm-cleanup should call this utility as well, so it will remove everything, and not just rhev-m


I suggest adding this functionality to rhevm-cleanup instead of writing a separate tool, but that's not necessary

Comment 3 RHEL Product and Program Management 2013-06-09 09:45:09 UTC
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Comment 5 Yaniv Lavi 2013-10-28 15:00:03 UTC
You can use this kbase:
https://access.redhat.com/site/solutions/291973

and the rpm uninstall clause to see the needed steps.


Yaniv

Comment 7 Sandro Bonazzola 2014-02-13 15:20:16 UTC
Since we've otopi based setup, cleanup should now be available just running engine-cleanup.

Comment 8 Barak Dagan 2014-03-05 13:56:06 UTC
Verified on av2

rhevm-dwh-3.4.0-0.4.master.20140224152332.el6ev.noarch
rhevm-dwh-setup-3.4.0-0.4.master.20140224152332.el6ev.noarch

rhevm-reports-3.4.0-0.4.master.20140226133324.el6ev.noarch
rhevm-reports-setup-3.4.0-0.4.master.20140226133324.el6ev.noarch

jasperreports-server-pro-5.5.0-7.el6ev.noarch

answerfile:
OVESETUP_REMOVE/confirmUninstallGroups=bool:True
OVESETUP_REMOVE/removeAll=bool:True
OVESETUP_REMOVE/database=bool:True
OVESETUP_REMOVE/enabledFileGroups=str:,ca_pki,versionlock,ca_config,core,ssl,versionlock,ovirt_reports_files,ovirt_dwh_files,core
OVESETUP_DWH_REMOVE/database=bool:True
OVESETUP_REPORTS_REMOVE/database=bool:True



bash-4.1$ psql -l
                                             List of databases
         Name         |        Owner         | Encoding |  Collation  |    Ctype    |   Access privileges   
----------------------+----------------------+----------+-------------+-------------+-----------------------
 engine               | engine               | UTF8     | en_US.UTF-8 | en_US.UTF-8 | 
 ovirt_engine_history | ovirt_engine_history | UTF8     | en_US.UTF-8 | en_US.UTF-8 | 
 ovirt_engine_reports | ovirt_engine_reports | UTF8     | en_US.UTF-8 | en_US.UTF-8 | 
 postgres             | postgres             | UTF8     | en_US.UTF-8 | en_US.UTF-8 | 
 template0            | postgres             | UTF8     | en_US.UTF-8 | en_US.UTF-8 | =c/postgres
                                                                                    : postgres=CTc/postgres
 template1            | postgres             | UTF8     | en_US.UTF-8 | en_US.UTF-8 | =c/postgres
                                                                                    : postgres=CTc/postgres


bash-4.1$ psql -d engine -c '\d'
No relations found.
bash-4.1$ psql -d ovirt_engine_history -c '\d'
No relations found.
bash-4.1$ psql -d ovirt_engine_reports -c '\d'
No relations found.

Comment 9 errata-xmlrpc 2014-06-09 15:16:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0601.html


Note You need to log in before you can comment on or make changes to this bug.