Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86360 - TB: Conf.py:936:__setitem__
Summary: TB: Conf.py:936:__setitem__
Keywords:
Status: CLOSED DUPLICATE of bug 71171
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: redhat-config-network
Version: 2.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-20 15:33 UTC by Mathew May
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:15 UTC


Attachments (Terms of Use)

Description Mathew May 2003-03-20 15:33:19 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible: I can reproduce this error every single time.


Steps to Reproduce:
1. Open the Network Hardware Configuration GUI in the KDE desktop
2. Click on apply, whether changes have been made or not
3.
    
Actual results:I receive the following error:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 392, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 271, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 283, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-
network/netconfpkg/NCHardwareList.py", line 276, in save
    modules.write()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 
981, in write
    self[key] = self.vars[key]
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 
936, in __setitem__
    replace = key + ' ' + varname + ' ' + endofline
TypeError: illegal argument type for built-in operation

Local variables in innermost frame:
endofline: None
value: {'alias': None}
self: <netconfpkg.NCHardwareList.MyConfModules instance at 8464a28>
varname: eth1
missing: 1
key: alias
place: 0
findexp: [	 ]*alias[	 ]+eth1[	 ]+



Expected results: I would assume that the configration changes would be saved 
and that a reboor might be required for the changes to go into effect.


Additional info:

Comment 1 Phil Knirsch 2003-05-21 16:10:12 UTC
Reassigning to correct component.

Read ya, Phil


Comment 2 Harald Hoyer 2003-05-21 16:30:00 UTC

*** This bug has been marked as a duplicate of 71171 ***

Comment 3 Harald Hoyer 2003-05-21 16:31:15 UTC
An errata has been issued which should help the problem described in this bug
report. 
This report is therefore being closed with a resolution of ERRATA. For more
information
on the solution and/or where to find the updated files, please follow the link
below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-267.html


Comment 4 Red Hat Bugzilla 2006-02-21 18:52:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.