Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86354 - upgrade of glibc packages causes anonftp %triggers to run, but they fail
Summary: upgrade of glibc packages causes anonftp %triggers to run, but they fail
Keywords:
Status: CLOSED DUPLICATE of bug 85237
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anonftp
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-20 09:38 UTC by Bishop Clark
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:15 UTC


Attachments (Terms of Use)

Description Bishop Clark 2003-03-20 09:38:27 UTC
Description of problem:
Upgrade of glibc packages via rpm -Fvh causes this output:


Preparing...                ########################################### [100%]
   1:glibc-common           ########################################### [ 25%]
   2:glibc                  ########################################### [ 50%]
chmod: getting attributes of `/var/ftp/lib/libs.md5': Not a directory
touch: creating `/var/ftp/etc/ld.so.conf': No such file or directory
/sbin/ldconfig: Can't open configuration file /etc/ld.so.conf: No such file or
directory
/sbin/ldconfig: Can't create temporary cache file /etc/ld.so.cache~: No such
file or directory
error: execution of %trigger scriptlet from anonftp-4.0-9 failed, exit status 1
   3:glibc-devel            ########################################### [ 75%]
   4:nscd                   ########################################### [100%]

Consequently, the rpm-Fvh of glibc main package will report a FAILURE, and one's
RPMdb will have duplicate glibc package entries - NOT something one wants to
mess about with.

Version-Release number of selected component (if applicable):

glibc-2.2.5-42
glibc-2.2.5-43
anonftp-4.0-9

How reproducible:

At least once.  I'm not doing this anywhere else, as I don't have any more
servers I'll risk potentially hosing.

Steps to Reproduce:
1. rpm -i anonftp-4.0-9*rpm
2. rpm -Fvh glibc-*2.2.5-43*rpm
3.
    
Actual results:
as above

Expected results:

Preparing...                ########################################### [100%]
   1:glibc-common           ########################################### [ 25%]
   2:glibc                  ########################################### [ 50%]
   3:glibc-devel            ########################################### [ 75%]
   4:nscd                   ########################################### [100%]

Additional info:

Comment 1 Thomas Woerner 2003-04-16 10:17:08 UTC

*** This bug has been marked as a duplicate of 85237 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.