Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86338 - Cannot ad groups to roles
Summary: Cannot ad groups to roles
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other
Version: nightly
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bryan Che
QA Contact: Jon Orris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-20 00:33 UTC by Richard Li
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-09-05 17:53:42 UTC


Attachments (Terms of Use)

Description Richard Li 2003-03-20 00:33:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
From Exscend: "I created multiple groups, then tried to assign them to roles. 
This was successful, but then the users attached to the groups were not able to
create content util I added them specifically to the roles. "

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See above.
    

Additional info:

Comment 1 Scott Seago 2003-04-25 20:09:18 UTC
I added this to SDM(#229088), but I fixed this on the london branch:

Fixed on london 5.2 branch @29984:

Adding groups to roles now allows members of those groups to receive and lock
CMS task assignments. Modified getEnabledUserTasks to use group_member_trans_map
instead of group_member_map, and fixed the query string used in PartyInfo so
that role details for a group uses the correct query (rather than the user query). 

Comment 2 Bryan Che 2003-05-02 20:50:45 UTC
I tried this on the trunk at changelist 30556 but could not reproduce it: adding
a group to a role gave the users the role's permissions.  I'll try it on the 5.2
branch once 5.2.1 is released.

Comment 3 Bryan Che 2003-05-15 15:41:07 UTC
fixed on 5.2 at 31144

Comment 4 Jon Orris 2006-09-05 17:53:42 UTC
Closing old tickets





Note You need to log in before you can comment on or make changes to this bug.