Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86337 - Plain US keyboard layout cannot be restored
Summary: Plain US keyboard layout cannot be restored
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Rockai
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-19 22:47 UTC by Zenon Panoussis
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version: 3.5.1-5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-07-18 07:28:11 UTC


Attachments (Terms of Use)

Description Zenon Panoussis 2003-03-19 22:47:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206


Description of problem:
Using kcontrol to configure multiple keyboard layouts. Country is Greece OR
Netherlands OR Sweden, primary language is English US, secondary language is
Greek OR none, keyboard is 101 or 104 keys (tested all possible combinations of
the above); these settings make no difference whatsoever for the following.

With X, Y and US English (us) keyboards defined and US English as the default,
switching from US to X or Y works fine. Switching from X or Y back to US doesn't
work at all and leaves the previously set keyboard active (i,e. you switch from
Greek to US and you still have Greek). Logging out and back in makes no
difference. Logging out and back in on "KDE" instead of "default", in an attempt
to force new defaults, makes no difference either. The *only* way to restore the
US keyboard is to use kcontrol to remove all other keyboard definitions, leaving
only US English. I tried several different combinations of X and Y (Greek,
Arabic, Georgian, Thai) and the problem is always the same. 

Trying to type on the command line and getting Greek is a tad frustrating. 

With X, Y and US English w/deadkeys (instead of US English) keyboards defined,
the problem disappears. Switching works perfectly from any definition to any,
even without closing applications, let alone logging out. It just works as it
should. 

Thus, I assume that something is broken in the US English keyboard definition.


Version-Release number of selected component (if applicable):
kdebase-3.1-7 & kdebase-3.1-9


Additional info:

Did not try US w/deadkeys with kdebase-3.1-7; I had already upgraded when I got
the idea of trying a different US keyboard definition than US English.

Comment 1 Petr Rockai 2006-07-17 18:20:53 UTC
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.

Comment 2 Zenon Panoussis 2006-07-18 06:10:15 UTC
I just tested it on Cent^wRHEL 4.3. The problem has gone away. 


Note You need to log in before you can comment on or make changes to this bug.