Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86310 - slrn is unable to display cyrillic text in UTF-8 locale
Summary: slrn is unable to display cyrillic text in UTF-8 locale
Keywords:
Status: CLOSED DUPLICATE of bug 75191
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: slrn
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-19 12:38 UTC by Alexey Neyman
Modified: 2013-07-02 22:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-08 15:11:33 UTC


Attachments (Terms of Use)
slrn screenshot (deleted)
2003-03-19 12:39 UTC, Alexey Neyman
no flags Details

Description Alexey Neyman 2003-03-19 12:38:55 UTC
Description of problem:  
slrn cannot display the cyrillic text. If the newsserver serves them in  
the KOI8-R encoding, the cyrillic text is not display at all (blank  
symbols appear). If the server enconding is UTF-8, the content is hardly  
readable (see screenshot): most of the symbols are replaced with question  
marks.  
 
I guess there are two problems: 
First, it seems not to convert the article to the UTF-8 character set 
(and in its config file, /etc/slrn.rc, utf-8 is not indicated as a valid 
charset value). 
Second, it seems that it incorrectly determines printable characters even 
for UTF-8 charset. 
  
Version-Release number of selected component (if applicable):  
slrn-0.9.7.4  
  
How reproducible:  
Run slrn on any USENET group with Russian posts.

Comment 1 Alexey Neyman 2003-03-19 12:39:46 UTC
Created attachment 90661 [details]
slrn screenshot

Comment 2 Jindrich Novy 2005-09-08 15:11:33 UTC

*** This bug has been marked as a duplicate of 75191 ***


Note You need to log in before you can comment on or make changes to this bug.