Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 863074 - UserRole permission on System/DC/Cluster doesn't work as expected
Summary: UserRole permission on System/DC/Cluster doesn't work as expected
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Ravi Nori
QA Contact: Ondra Machacek
URL:
Whiteboard: infra
: 904984 (view as bug list)
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2012-10-04 11:53 UTC by Oved Ourfali
Modified: 2016-02-10 19:10 UTC (History)
16 users (show)

Fixed In Version: ovirt-3.5.0-alpha2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:08:22 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 28041 master MERGED engine: UserRole permission on System/DC/Cluster doesn't work as expected Never
Red Hat Bugzilla 839490 None None None Never

Description Oved Ourfali 2012-10-04 11:53:36 UTC
Description of problem:
When granting UserRole permission on System/DC/Cluster, it allows the user to see all the VMs under that entity (System/DC/Cluster), including Pooled VMs.
The result is that he will see all the VMs (including the Pooled VM) in the User Portal, but he won't see the VM Pools (as the logic is to show only pools that the user has no UserRole on at least one VM from this pool).

Currently opening the bug on backend, but we need to decide on what level we solve this issue.

Version-Release number of selected component (if applicable):
3.1

How reproducible:
Always

Steps to Reproduce:
1. Create a VM Pool with 2 VMs
2. Grant the user with UserRole on System/DC/Cluster
3. Login to the user portal
  
Actual results:
You'll see the two pooled VMs, but not the pool itself.

Expected results:
You should see the pools, and not the pooled VMs, and be able to run the pool, and get a VM that is assigned to you from this pool (after you run it the pool will disappear from the User Portal view, and you'll see the assigned VM).

Additional info:
See Bug #839490

Comment 1 Jiri Belka 2013-03-06 13:32:15 UTC
*** Bug 904984 has been marked as a duplicate of this bug. ***

Comment 8 Itamar Heim 2013-12-01 10:10:18 UTC
oved, didn't we clean some of this up?

Comment 9 Oved Ourfali 2013-12-22 18:53:34 UTC
Sorry for that late response. Just now noticed the question.
I didn't work on that one. Not sure if another work gave some resolution to this issue. I think that addressing Bug 878812 might also solve this one, so if it is planned to be solved soon then we can wait with this one.

Comment 12 Eli Mesika 2014-02-18 20:49:49 UTC
Looked at 878812 and it this seems to me as a duplicate, agree ???

Comment 13 Oved Ourfali 2014-02-19 05:51:56 UTC
It is not a duplicate.
It is true that solving Bug #878812 will help this one, but in order to make sure all the issues are addressed I prefer to leave this one open as well.
Added a dependency to this bug on Bug #878812

Comment 16 Ondra Machacek 2014-08-14 09:35:28 UTC
User now can see all VM pools which he has direct/inderect permissions and user can't see pools where he exceeded limit of allocation of vms.

User can see all vms which he has direct/inderect permissions for and all vms from pool which he has allocated.

Comment 17 Eyal Edri 2015-02-17 17:08:22 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.