Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86300 - Nautilus does not give write permissions to NFS mounted folders
Summary: Nautilus does not give write permissions to NFS mounted folders
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-19 07:02 UTC by Youssef Makki
Modified: 2015-01-08 00:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-04-24 20:42:49 UTC


Attachments (Terms of Use)

Description Youssef Makki 2003-03-19 07:02:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:
When using Nautilus to browse an NFS mounted folder no write permissions are
given knowing that my regular user account has rwx permissions; it works fine
through a console/terminal. Nautilus will not allow me to modify or create
files/directories in the locally mounted NFS folder unless I launch Nautilus as
root.

The NFS server is an RH 7.3, kernel-2.4.18-26.7.x, nfs-utils-0.3.3-5.
The client is an RH 8.0, kernel-2.4.18-26.8.0

The NFS share is configured with:
/path/to/dir ip.of.client(rw,all_squash,anonuid=0,anongid=0)
mounted on the client with:
ip.of.server:/path/to/dir /mnt/nfs     nfs     rw,hard,intr    0 0


Version-Release number of selected component (if applicable):
nautilus-2.0.6-6

How reproducible:
Always

Steps to Reproduce:
1. mount nfs share
2. browse to /mnt/nfs with Nautilus
3. try to edit a file or create a new folder


Actual Results:  No rw permissions in Nautilus

Expected Results:  rw permissions should be given to regular user

Additional info:

Comment 1 Youssef Makki 2004-02-27 22:27:52 UTC
This bug still exists in Fedora Core 1, should I submit a new report?


Comment 2 Alexander Larsson 2004-03-01 14:44:23 UTC
Not needed. 

Comment 3 Alexander Larsson 2004-10-04 13:22:01 UTC
Does this work in fc3 test3? I can't reproduce it when i try it on my
system.

Comment 4 John Thacker 2006-04-24 20:42:49 UTC
No response from reporter; closing.


Note You need to log in before you can comment on or make changes to this bug.